Bug 1798834 - Hosted engine redeploy failed at "Add IPv4 outbound route rules" ansible task.
Summary: Hosted engine redeploy failed at "Add IPv4 outbound route rules" ansible task.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ovirt-4.3.9
: 2.3.13
Assignee: Evgeny Slutsky
QA Contact: Wei Wang
URL:
Whiteboard:
Depends On:
Blocks: 1812417
TreeView+ depends on / blocked
 
Reported: 2020-02-06 05:51 UTC by Wei Wang
Modified: 2020-03-20 07:57 UTC (History)
14 users (show)

Fixed In Version: ovirt-hosted-engine-setup-2.3.13
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-20 07:57:09 UTC
oVirt Team: Integration
Embargoed:
sbonazzo: ovirt-4.3?
sbonazzo: blocker?
sbonazzo: planning_ack?
sbonazzo: devel_ack+
weiwang: testing_ack+


Attachments (Terms of Use)
log_20200206 (2.03 MB, application/gzip)
2020-02-06 05:55 UTC, Wei Wang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github oVirt ovirt-ansible-hosted-engine-setup pull 294 0 None closed Fix ipv4 inbound/outbound condition on el8 (4.4) 2020-12-10 17:32:50 UTC
oVirt gerrit 107427 0 master MERGED Remove IP Rules on ovirt-hosted-engine-cleanup 2020-12-10 17:32:50 UTC
oVirt gerrit 107429 0 ovirt-hosted-engine-setup-2.3 MERGED Remove IP Rules on ovirt-hosted-engine-cleanup 2020-12-10 17:32:50 UTC

Description Wei Wang 2020-02-06 05:51:51 UTC
Description of problem:
Hosted engine redeploys failed as below message:
[ INFO ] TASK [ovirt.hosted_engine_setup : Add IPv4 outbound route rules]
[ ERROR ] fatal: [localhost]: FAILED! => {"changed": true, "cmd": ["ip", "rule", "add", "from", "192.168.222.1/24", "priority", "101", "table", "main"], "delta": "0:00:00.003285", "end": "2020-02-06 13:46:46.603994", "msg": "non-zero return code", "rc": 2, "start": "2020-02-06 13:46:46.600709", "stderr": "RTNETLINK answers: File exists", "stderr_lines": ["RTNETLINK answers: File exists"], "stdout": "", "stdout_lines": []}

Version-Release number of selected component (if applicable):
RHVH-4.3-20200204.0-RHVH-x86_64-dvd1.iso
cockpit-195.3-1.el7.x86_64
cockpit-dashboard-195-1.el7.x86_64
cockpit-bridge-195.3-1.el7.x86_64
cockpit-storaged-195-1.el7.noarch
cockpit-ovirt-dashboard-0.13.9-1.el7ev.noarch
cockpit-system-195.3-1.el7.noarch
cockpit-ws-195.3-1.el7.x86_64
cockpit-machines-ovirt-195-1.el7.noarch
rhvm-appliance-4.3-20200204.0.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Clean install 
2. Deploy hosted engine
3. Clean hosted engine
4. redeploy hosted engine

Actual results:
Hosted engine redeploy failed.

Expected results:
Hosted engine redeploy successfully without any error

Additional info:

Comment 1 Wei Wang 2020-02-06 05:55:20 UTC
Created attachment 1658095 [details]
log_20200206

Comment 2 Gal Zaidman 2020-02-06 06:36:36 UTC
Wei Wang how did you clean the hosted engine on step 3?

Comment 3 Wei Wang 2020-02-06 09:25:10 UTC
(In reply to Gal Zaidman from comment #2)
> Wei Wang how did you clean the hosted engine on step 3?

Using the clean script "/usr/sbin/ovirt-hosted-engine-cleanup"

Comment 4 Evgeny Slutsky 2020-02-26 08:59:18 UTC
its  reproduced also in 4.4 master

Comment 5 Evgeny Slutsky 2020-03-05 10:50:01 UTC
this patch https://gerrit.ovirt.org/#/c/107427/ work on  both 4.3 and 4.4 ,
this patch is for 4.4  https://github.com/oVirt/ovirt-ansible-hosted-engine-setup/pull/294 only

Comment 7 Wei Wang 2020-03-12 03:18:56 UTC
QE will verify this bug until getting new 4.3.9 build.

Comment 8 Wei Wang 2020-03-13 12:14:37 UTC
Test Version
rhvh-4.3.9.2-0.20200311.0
rhvm-appliance-4.3-20200311.0.el7.x86_64
cockpit-ovirt-dashboard-0.13.9-1.el7ev.noarch
cockpit-dashboard-195.5-2.el7.x86_64
cockpit-system-195.5-2.el7.noarch
cockpit-storaged-195.5-2.el7.noarch
cockpit-machines-ovirt-195.5-2.el7.noarch
cockpit-ws-195.5-2.el7.x86_64
cockpit-195.5-2.el7.x86_64
cockpit-bridge-195.5-2.el7.x86_64

Test steps:
According to comment 0

Result:
Hosted engine redeploy successful.

Move the status to "VERIFIED"

Comment 9 Sandro Bonazzola 2020-03-20 07:57:09 UTC
This bugzilla is included in oVirt 4.3.9 release, published on March 20th 2020.

Since the problem described in this bug report should be
resolved in oVirt 4.3.9 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.