Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1812417 - Hosted engine redeploy failed at "Add IPv4 outbound route rules" ansible task.
Summary: Hosted engine redeploy failed at "Add IPv4 outbound route rules" ansible task.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup
Version: 4.3.9
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ovirt-4.3.9
: 4.3.9
Assignee: Evgeny Slutsky
QA Contact: Wei Wang
URL:
Whiteboard:
Depends On: 1798834
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-11 09:56 UTC by Asaf Rachmani
Modified: 2020-04-02 16:32 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Rebase: Bug Fixes Only
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-02 16:32:08 UTC
oVirt Team: Integration
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1307 0 None None None 2020-04-02 16:32:11 UTC

Description Asaf Rachmani 2020-03-11 09:56:31 UTC
Description of problem:
Hosted engine redeploys failed as below message:
[ INFO ] TASK [ovirt.hosted_engine_setup : Add IPv4 outbound route rules]
[ ERROR ] fatal: [localhost]: FAILED! => {"changed": true, "cmd": ["ip", "rule", "add", "from", "192.168.222.1/24", "priority", "101", "table", "main"], "delta": "0:00:00.003285", "end": "2020-02-06 13:46:46.603994", "msg": "non-zero return code", "rc": 2, "start": "2020-02-06 13:46:46.600709", "stderr": "RTNETLINK answers: File exists", "stderr_lines": ["RTNETLINK answers: File exists"], "stdout": "", "stdout_lines": []}

Version-Release number of selected component (if applicable):
RHVH-4.3-20200204.0-RHVH-x86_64-dvd1.iso
cockpit-195.3-1.el7.x86_64
cockpit-dashboard-195-1.el7.x86_64
cockpit-bridge-195.3-1.el7.x86_64
cockpit-storaged-195-1.el7.noarch
cockpit-ovirt-dashboard-0.13.9-1.el7ev.noarch
cockpit-system-195.3-1.el7.noarch
cockpit-ws-195.3-1.el7.x86_64
cockpit-machines-ovirt-195-1.el7.noarch
rhvm-appliance-4.3-20200204.0.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Clean install 
2. Deploy hosted engine
3. Clean hosted engine
4. redeploy hosted engine

Actual results:
Hosted engine redeploy failed.

Expected results:
Hosted engine redeploy successfully without any error

Additional info:

Comment 1 RHEL Program Management 2020-03-11 09:59:08 UTC
The documentation text flag should only be set after 'doc text' field is provided. Please provide the documentation text and set the flag to '?' again.

Comment 4 Wei Wang 2020-03-12 03:18:24 UTC
QE will verify this bug until getting new 4.3.9 build.

Comment 5 Wei Wang 2020-03-13 12:14:24 UTC
Test Version
rhvh-4.3.9.2-0.20200311.0
rhvm-appliance-4.3-20200311.0.el7.x86_64
cockpit-ovirt-dashboard-0.13.9-1.el7ev.noarch
cockpit-dashboard-195.5-2.el7.x86_64
cockpit-system-195.5-2.el7.noarch
cockpit-storaged-195.5-2.el7.noarch
cockpit-machines-ovirt-195.5-2.el7.noarch
cockpit-ws-195.5-2.el7.x86_64
cockpit-195.5-2.el7.x86_64
cockpit-bridge-195.5-2.el7.x86_64

Test steps:
According to comment 0

Result:
Hosted engine redeploy successful.

Move the status to "VERIFIED"

Comment 7 errata-xmlrpc 2020-04-02 16:32:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1307


Note You need to log in before you can comment on or make changes to this bug.