Bug 1798871 - Start button is still disabled although all Required fields are filled in Start Pipeline modal
Summary: Start button is still disabled although all Required fields are filled in Sta...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Rohit Rai
QA Contact: Ruchir Garg
URL:
Whiteboard:
Depends On:
Blocks: 1799047
TreeView+ depends on / blocked
 
Reported: 2020-02-06 08:06 UTC by Yadan Pei
Modified: 2020-05-04 11:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-04 11:34:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4266 None closed Bug 1798871: Fix formik low priority validation issues 2020-05-01 22:08:12 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:34:34 UTC

Description Yadan Pei 2020-02-06 08:06:31 UTC
Description of problem:
Although all required fields are prefilled in Start Pipeline modal, Start button is still disabled. 

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-02-05-220946

How reproducible:
Always

Steps to Reproduce:
1. enable OpenShift Pipelines Operator and create some pipelines related resources
$ oc new-project pipelines-tutorial
Create Tasks
$ oc create -f https://raw.githubusercontent.com/openshift/pipelines-tutorial/master/pipeline/update_deployment_task.yaml
$ oc create -f https://raw.githubusercontent.com/openshift/pipelines-tutorial/master/pipeline/apply_manifest_task.yaml
Create Pipeline
$ oc create -f https://raw.githubusercontent.com/openshift/pipelines-tutorial/master/pipeline/pipeline.yaml
Create Pipeline resources
$ oc create -f https://raw.githubusercontent.com/openshift/pipelines-tutorial/master/pipeline/resources.yaml
2. Trigger Pipeline Run from console Pipelines -> Pipelines -> build-and-deploy -> click 'Start' from kebab action list


Actual results:
2. Start Pipeline modal is opened, although every required fields are prefilled,  Start button is still disabled, user can't trigger Pipeline Runs. The Start button is only enabled after each fields is changed to a different value then default ones

Expected results:
2. When every required field is set correctly, user should be able to submit the action

Additional info:

Comment 3 Yadan Pei 2020-02-19 05:57:56 UTC
When every field is filled correctly in Start Pipeline modal, Start button is enabled and can trigger Pipeline Runs successfully


Verified on     4.4.0-0.nightly-2020-02-18-164016

Comment 5 errata-xmlrpc 2020-05-04 11:34:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.