Bug 179942 - gdm crashes after entering user name
gdm crashes after entering user name
Status: CLOSED DUPLICATE of bug 179941
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-03 18:26 EST by Zachary Whitley
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-04 11:21:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zachary Whitley 2006-02-03 18:26:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051201 Fedora/1.5-1.1.fc4.nr Firefox/1.5

Description of problem:
gdm crashes after entering user name. It's fine when you enter the name but crashes when you hit return.

I have no idea exactly what caused this problem to appear. My machine always on so I didn't notice a problem until I rebooted so I'm not sure exactly what package caused the error to appear. I think the problem is with gdm but that the installation of some other package caused it to appear.

ie. gdm has problem that didn't cause it to crash. Package A updates something => gdm problem now crashes.

After I started having problems I uninstalled gdm and reinstalled rpm -e gdm; yum install gdm. Didn't fix the problem. Then I downgraded to the version shipped with fc4 (gdm-2.6.8-16) which was working fine when I installed fc4. Still had problem.

Changed to init 3 and ran startx....works fine. Problem was with gdm.

Changed back to init 5. Tried using tab key instead of enter key: success.

changed enable=TRUE in gdm.conf. Tried logging in using enter to cause crash found this in log file:

gdmgreeter[27009]: Unexpected greeter command received: 'FF'

(wasn't FF but I'm assiming unicode character with an F in the upper left and an F in the lower right) 

Version-Release number of selected component (if applicable):
gdm-2.8.0.7-1.1.fc4.nr

How reproducible:
Always

Steps to Reproduce:
1.login with gdm
2.crash
3."unexpected greeter comand received" in logs 
  

Additional info:
Comment 1 David Eisenstein 2006-02-04 11:21:58 EST

*** This bug has been marked as a duplicate of 179941 ***

Note You need to log in before you can comment on or make changes to this bug.