Bug 179943 - udev-071-0.FC4.2 breaks Display for Radeon: Missing /dev/dri/card0
udev-071-0.FC4.2 breaks Display for Radeon: Missing /dev/dri/card0
Status: CLOSED DUPLICATE of bug 179041
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-03 18:55 EST by Frank Schmitt
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-06 03:56:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
X11 logfile for the broken session (35.63 KB, text/plain)
2006-02-03 18:56 EST, Frank Schmitt
no flags Details

  None (edit)
Description Frank Schmitt 2006-02-03 18:55:07 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Description of problem:
I just updated to kernel-2.6.15-1.1830_FC4 and udev-071-0.FC4.2. After a reboot, everything was normal until start of X (login manager already broken, no errors while bootup, I don't use rhgb). The display in X was completely broken: I saw mainly grey horizontal bars but also some stuff on my desktop but in a resolution like say 200x100. I'm using a Thinkpad R40 with a Radeon Mobility 7500.

I rebooted into kernel-2.6.14-1.1656_FC4 and the problem persisted, downgrading udev to udev-058-1.0.FC4.1 fixed the problem. In my Xorg.0.log I found:
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (Unknown error 999)
drmOpenDevice: open result is -1, (Unknown error 999)
drmOpenDevice: Open failed
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is -1, (Unknown error 999)
drmOpenDevice: open result is -1, (Unknown error 999)
drmOpenDevice: Open failed
drmOpenByBusid: Searching for BusID pci:0000:01:00.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 9, (OK)
drmOpenByBusid: drmOpenMinor returns 9
drmOpenByBusid: drmGetBusid reports pci:0000:01:00.0
which looks rather strange.

Here's the output of lspci:
00:00.0 Host bridge: Intel Corporation 82855PM Processor to I/O Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 82855PM Processor to AGP Controller (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 81)
00:1f.0 ISA bridge: Intel Corporation 82801DBM (ICH4-M) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801DBM (ICH4-M) IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 01)
00:1f.5 Multimedia audio controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
00:1f.6 Modem: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]
02:00.0 CardBus bridge: Texas Instruments PCI1510 PC card Cardbus Controller
02:02.0 Network controller: AIRONET Wireless Communications Cisco Aironet Wireless 802.11b
02:08.0 Ethernet controller: Intel Corporation 82801DB PRO/100 VE (MOB) Ethernet Controller (rev 81)

I'll attach full Xorg.0.log


Version-Release number of selected component (if applicable):
udev-071-0.FC4.2

How reproducible:
Always

Steps to Reproduce:
1. Update to udev-071-0.FC4.2 using a Thinkpad R40
2. Reboot
3. See broken X
  

Actual Results:  X display was broken

Expected Results:  It shouldn't have been

Additional info:
Comment 1 Frank Schmitt 2006-02-03 18:56:58 EST
Created attachment 124138 [details]
X11 logfile for the broken session
Comment 2 Mike Perrin 2006-02-04 21:56:35 EST
Symptom: Graphic login screen is grayscale and distorted/disjointed.
         Login is accepted but X-window corruption persists.
         Can be corrected by CTRL-ALT-BACKSPACE, after which
         the graphic login and user screens are normal.

Observations:
- Occurs with ATI Radeon 7000 graphic card and radeon driver.
- Does not occur with nVidia GeForce 2 MX card and nv driver on
  otherwise identical system (ASUS A7V-133C, Athlon 1000/266, 512MB).
- Does not occur if xorg.conf driver is changed from "radeon" to "vesa".
- Occurs with kernel 2.6.14-1.1656_FC4 and 2.6.15-1.1830_FC4.
- Occurs if inital run level is 3 and startx is invoked.
- Does not occur if initial run level is 3 and gdm is invoked.
Comment 3 Harald Hoyer 2006-02-06 03:56:55 EST

*** This bug has been marked as a duplicate of 179041 ***

Note You need to log in before you can comment on or make changes to this bug.