Bug 179041 - udev-071-0.FC4.2 gives streaked login screen
udev-071-0.FC4.2 gives streaked login screen
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: module-init-tools (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
: 179899 179943 179951 179989 180003 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-01-26 15:26 EST by Fred New
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-09 04:23:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Fred New 2006-01-26 15:26:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:


Version-Release number of selected component (if applicable):
udev-071-0.FC4.1

How reproducible:
Always

Steps to Reproduce:
1. Install udev-071-0.FC4.1
2. Boot system with rhgb
  

Actual Results:  The booting process fails to transition from rhgb to the X login screen.  The login screen I get has vertical streaks a large X for the mouse.  If I wait about 30 seconds, the X goes away, but the rest of the screen doesn't change.  After about 1,5 minutes, the areas that look like "Fedora" and other non-background features disappear.  At this time I can <Ctrl><Alt><F1> to get to a console and <Alt><F7> back to get a good login screen.

Expected Results:  I should get a login screen I can log in with.

Additional info:

kernel-2.6.15-1.1824_FC4

Here are the last few lines of dmesg with udev-071-0.FC4.1:

[drm] Initialized drm 1.0.0 20040925
[drm] Initialized r128 2.5.0 20030725 on minor 0:
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 1x mode
agpgart: Putting AGP V2 device at 0000:02:00.0 into 1x mode
aty128fb: Found Intel x86 BIOS ROM Image
aty128fb: Rage128 BIOS located
aty128fb: Rage128 PF PRO AGP [chip rev 0x1] 16M 128-bit SDR SGRAM (1:1)
Console: switching to colour frame buffer device 80x30
fb0: ATY Rage128 frame buffer device on Rage128 PF PRO AGP
aty128fb: Rage128 MTRR set to ON
application mixer_applet2 uses obsolete OSS audio interface

Here are the last few lines with udev-058-1.0.FC4.1:

[drm] Initialized drm 1.0.0 20040925
[drm] Initialized r128 2.5.0 20030725 on minor 0:
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 1x mode
agpgart: Putting AGP V2 device at 0000:02:00.0 into 1x mode
application mixer_applet2 uses obsolete OSS audio interface
Comment 1 Harald Hoyer 2006-01-27 01:20:36 EST
Does it help if you add this to /etc/modprobe.conf??

# framebuffer drivers
blacklist aty128fb
blacklist atyfb
blacklist radeonfb
blacklist i810fb
blacklist cirrusfb
blacklist intelfb
blacklist kyrofb
blacklist i2c-matroxfb
blacklist hgafb
blacklist nvidiafb
blacklist rivafb
blacklist savagefb
blacklist sstfb
blacklist neofb
blacklist tridentfb
blacklist tdfxfb
blacklist virgefb
blacklist vga16fb
Comment 2 Fred New 2006-01-28 04:40:36 EST
No, I just get a bunch of messages like

Jan 28 11:31:49 darth modprobe: WARNING: /etc/modprobe.conf line 13: ignoring
bad line starting with 'blacklist'

Can you suggest something a little different?  Just to be clear, this is FC4
with module-init-tools-3.1-4.  I notice these modules are all listed in
/etc/hotplug/blacklist.
Comment 3 Harald Hoyer 2006-01-30 02:32:12 EST
Ok, s.th. like

alias aty128fb none

should work for fc4.
Comment 4 Harald Hoyer 2006-01-30 02:37:13 EST
Even better:

install aty128fb /bin/true
Comment 5 Fred New 2006-01-30 13:59:50 EST
Yep, that fixes the problem.
Comment 6 Fred New 2006-02-01 00:57:17 EST
This bug is still present in udev-071-0.FC4.2.  That is, I tried it without the
modprobe.conf change and aty128fb gets used, resulting in the unusable login screen.
Comment 7 Harald Hoyer 2006-02-02 10:29:56 EST
Please try module-init-tools-3.2-0.pre9.0.FC4.1
Comment 8 Fred New 2006-02-02 14:27:35 EST
Everything works with
  module-init-tools-3.2-0.pre9.0.FC4.1
  udev-071-0.FC4.2
  and modprobe.conf back to the way it was before this problem.

Thanks.
Comment 9 Alexei Podtelezhnikov 2006-02-03 11:49:48 EST
Hope it will help to fix my X.org and gdm login screen, which is trashed here 
with ATI r128. 
Comment 10 Fred New 2006-02-04 03:10:16 EST
Oh no!  The new udev got released into updates-released without the new
module-init-tools.  Now my non-test computer is showing these symptoms.  I know
how to fix it, but the rest of the FC4 non-test world is going to have problems.
Comment 11 Fred New 2006-02-04 03:21:52 EST
I installed module-init-tools-3.2-0.pre9.0.FC4.1 on my non-test system, but it
doesn't prevent this problem.  I have a different video adapter there.  The last
few lines of dmesg show:

agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 1x mode
agpgart: Putting AGP V2 device at 0000:01:00.0 into 1x mode
ACPI: PCI Interrupt 0000:01:00.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11
matroxfb: Matrox G550 detected
PInS memtype = 5
matroxfb: MTRR's turned on
matroxfb: 640x480x8bpp (virtual: 640x26214)
matroxfb: framebuffer at 0xF2000000, mapped to 0xf1800000, size 33554432
Console: switching to colour frame buffer device 80x30
fb0: MATROX frame buffer device
application mixer_applet2 uses obsolete OSS audio interface
Comment 12 Fred New 2006-02-04 03:43:06 EST
For this system, putting
   install matroxfb /bin/true
into /etc/modprobe.conf didn't work.  I used lsmod to find the name of the
module being used.  The login screen works normally after I put
   install matroxfb_base /bin/true
into /etc/modprobe.conf.
Comment 13 David Eisenstein 2006-02-04 10:52:05 EST
Bug 180003 seems to nearly duplicate behavior reported in comment 11 and 12.
Comment 14 Adam Pribyl 2006-02-04 11:59:37 EST
*** Bug 180003 has been marked as a duplicate of this bug. ***
Comment 15 Adam Pribyl 2006-02-04 12:03:14 EST
I described similar/same issue with matroxfb in bug 18003. According to my
opinion it is because frame buffer is initialized at same time as X is starting.
However I do not know what changed in udev that it always inserts FB module for
any video card at X start. The workaround in comment #12 will most probably fix
the problem. What I did is that I removed
/lib/modules/.../kernel/driver/video/matrox from modules tree, and login appears
as usuall.
Comment 16 Giovanni Corriga 2006-02-05 05:30:16 EST
I have the same problems on two systems of mine, a laptop and a desktop, both
with a Radeon video adapter. Installing module-init-tools-3.2-0.pre9.0.FC4.1
solves the problem, but after installation of this package, the radeonfb kernel
module doesn't get loaded at startup.
Comment 17 Fred New 2006-02-05 07:32:41 EST
I think we don't want to load the frame buffer driver at all if we are using
graphical mode (run level 5).  Someone please correct me if I am wrong.

The next build of udev should depend on a minimum version of module-init-tools.
 I thought this bug would have resulted in this change before udev-071-0.FC4.2
got released, but it looks like the latest kernel forced a premature push of udev.
Comment 18 Harald Hoyer 2006-02-06 03:54:49 EST
*** Bug 179899 has been marked as a duplicate of this bug. ***
Comment 19 Harald Hoyer 2006-02-06 03:57:14 EST
*** Bug 179943 has been marked as a duplicate of this bug. ***
Comment 20 Harald Hoyer 2006-02-06 03:57:59 EST
*** Bug 179951 has been marked as a duplicate of this bug. ***
Comment 21 tengel 2006-02-06 04:08:12 EST
This exact bug also happens on my ATI Rage Mobility M3, a Dell Latitude C600
laptop. Yes, it appears this udev got pushed out with the newest kernel, I
recommend marking this as a high priority to get fixed -- it took me quite a bit
of digging to figure out what was wrong and use links/bash to snatch the older
udev in order to get operational again. I dare say a lot of folks will never get
half as far as I did withoug any X (ergo Firefox/Mozilla) to search for help.
Comment 22 Adam Pribyl 2006-02-06 08:31:15 EST
Another system: Very similar problems with ATI Radeon 7500 too. The screen is
messed up when X starts. Restarting X helps but console is driven trought frame
buffer, which is not likely needed.

It is still not clear to me, what is the mechanism of this problem. It is clear
that it is cause by FB and X initialization at once. But why and who asks for fb
module insertion (udev, kernel, X (dri))? How could module-init-tools solve that?
Comment 23 Giovanni Corriga 2006-02-07 09:08:13 EST
A temporary workaround I found was switching from X to a virtual terminal and
then again to X. This solved the problem.
Comment 24 Dave Jones 2006-02-07 17:02:22 EST
*** Bug 179989 has been marked as a duplicate of this bug. ***
Comment 25 Frank Schmitt 2006-02-08 16:13:27 EST
The problem is gone for me with the latest updates (I guess the new
module-init-tools fixed it). Original description at
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=179943
Comment 26 Martin A. Boegelund 2006-02-08 16:21:35 EST
Problem gone for me too after update of module-init-tools.
Original description at https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=179989
Comment 27 Adam Pribyl 2006-02-10 16:46:10 EST
Still same for me with all these updates and matrox.
[drm] Initialized drm 1.0.0 20040925
[drm] Initialized mga 3.2.0 20050607 on minor 0: 
agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
agpgart: Putting AGP V2 device at 0000:00:00.0 into 1x mode
agpgart: Putting AGP V2 device at 0000:01:00.0 into 1x mode
matroxfb: Matrox Millennium G200 (AGP) detected
PInS memtype = 5
matroxfb: MTRR's turned on
matroxfb: 640x480x8bpp (virtual: 640x13107)
matroxfb: framebuffer at 0xDD000000, mapped to 0xe1480000, size 8388608
Console: switching to colour frame buffer device 80x30
fb0: MATROX frame buffer device

What's worse is that after this update I got lot of times this warining:
modprobe: WARNING: Failed to open included config file /etc/modprobe.conf.dist:
No such file or director

I found there was added "include /etc/modprobe.conf.dist" into
/etc/modprobe.conf, but the file is in /etc/modprobe.d/modprobe.conf.dist.
Comment 28 Adam Pribyl 2006-02-10 17:14:49 EST
On second system with ati radeon, new module-init-tools prevent radeonfb to be
loaded. Does anybody understand what has changed that it works for radeon but
not for matrox?
Comment 29 Fred New 2006-02-23 00:53:20 EST
There is a new update, module-init-tools-3.2-0.pre9.0.FC4.3, in the
updates-testing repository that fixes the matroxfb problem for me.

Note You need to log in before you can comment on or make changes to this bug.