Bug 179962 - wget appends to ".listing" files on revisits
wget appends to ".listing" files on revisits
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: wget (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
: Reopened
: 179963 179964 179965 179966 179967 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-03 21:59 EST by Mike McCaffrey
Modified: 2008-05-09 07:36 EDT (History)
0 users

See Also:
Fixed In Version: wget-1.10.2-8.fc6.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-09 07:36:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCaffrey 2006-02-03 21:59:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)

Description of problem:
The listing of the downloaded directory in the .listing file which is created by wget when visting ftp sites and which remains if the --no-remove-listing or --miror option is used grows after each download. Wget is appending to the .listing file and not re-creating it as it did in previous versions. Version is wget-1.10.2-0.fc4.i386.rpm.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Run wget with the --no-remove-listing or --mirror option on the same url twice and the .listing file will contain duplicate entries of the name(s) of the file(s) downloaded.
  

Actual Results:  On the second visting the directory listing was appended to the previous .listing file. 

Expected Results:  The .listing file should be a single listing of the files in the directory of the url visited.

Additional info:
Comment 1 David Eisenstein 2006-02-04 08:53:21 EST
*** Bug 179963 has been marked as a duplicate of this bug. ***
Comment 2 David Eisenstein 2006-02-04 08:58:52 EST
*** Bug 179964 has been marked as a duplicate of this bug. ***
Comment 3 David Eisenstein 2006-02-04 09:28:13 EST
*** Bug 179965 has been marked as a duplicate of this bug. ***
Comment 4 David Eisenstein 2006-02-04 09:32:16 EST
*** Bug 179966 has been marked as a duplicate of this bug. ***
Comment 5 David Eisenstein 2006-02-04 09:34:06 EST
*** Bug 179967 has been marked as a duplicate of this bug. ***
Comment 6 Karsten Hopp 2007-01-10 06:02:36 EST
Can you please retry with the latest wget packages which should show up on your
Fedora mirror tomorrow ? They contain a fix for bug 186195 which might solve
this one as well. Please reopen if the problem still exists.
Comment 7 Mike McCaffrey 2007-06-17 23:24:42 EDT
This problem persists.

wget-1.10.2-8.fc6 dated 2007-01-10 did not fix it

I have just installed fedora 7 and the problem is the same 
(wget-1.10.2-15.fc7)

To get things to work I rebuild wget-1.9.1-22

(In reply to comment #0)
> From Bugzilla Helper:
> User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
> 
> Description of problem:
> The listing of the downloaded directory in the .listing file which is created
by wget when visting ftp sites and which remains if the --no-remove-listing or
--miror option is used grows after each download. Wget is appending to the
.listing file and not re-creating it as it did in previous versions. Version is
wget-1.10.2-0.fc4.i386.rpm.
> 
> Version-Release number of selected component (if applicable):
> 
> 
> How reproducible:
> Always
> 
> Steps to Reproduce:
> 1.Run wget with the --no-remove-listing or --mirror option on the same url
twice and the .listing file will contain duplicate entries of the name(s) of the
file(s) downloaded.
>   
> 
> Actual Results:  On the second visting the directory listing was appended to
the previous .listing file. 
> 
> Expected Results:  The .listing file should be a single listing of the files
in the directory of the url visited.
> 
> Additional info:

Comment 8 Karsten Hopp 2007-06-18 10:18:19 EDT
ls -l .listing after first attempt of wget  --no-remove-listing
ftp://ftp.redhat.com/ :
-rw-rw-r-- 1 karsten karsten 61 18. Jun 16:13 .listing

ls -l .listing after second attempt of wget  --no-remove-listing
ftp://ftp.redhat.com/ :
-rw-rw-r-- 1 karsten karsten 61 18. Jun 16:14 .listing

 >rpm -q wget
wget-1.10.2-15.fc7

This doesn't look like wget is attaching to .listing, it is replacing it with
each run. The contents looks sane, too.
Please retry and make sure you're really using the binary from wget-1.10.2-15.fc7
Comment 9 Mike McCaffrey 2007-06-19 00:27:50 EDT
I am still getting the problem
The test below installs wget-1.91.1-22 and the .listing file is replaced with
each run
It then installs wget-1.10.2-15.fc7 and the .listing file grows

[root@polux i386]# . ./test
++ rpm -Uvh --force /usr/src/redhat/RPMS/x86_64/wget-1.9.1-22.x86_64.rpm
Preparing...                ########################################### [100%]
   1:wget                   ########################################### [100%]
++ rpm -q wget
wget-1.9.1-22
++ rm -i -f .listing
++ wget -m -nd -q -c
ftp://sunsite.mff.cuni.cz/MIRRORS/fedora.redhat.com/linux/releases/7/Live/i386/
++ ls --color=tty -l .listing
-rw-r--r-- 1 root root 231 2007-06-19 05:19 .listing
++ wget -m -nd -q -c
ftp://sunsite.mff.cuni.cz/MIRRORS/fedora.redhat.com/linux/releases/7/Live/i386/
++ ls --color=tty -l .listing
-rw------- 1 root root 231 2007-06-19 05:19 .listing
++ rpm -Uvh --force ../../Everything/x86_64/os/Fedora/wget-1.10.2-15.fc7.x86_64.rpm
Preparing...                ########################################### [100%]
   1:wget                   ########################################### [100%]
++ rpm -q wget
wget-1.10.2-15.fc7
++ rm -i -f .listing
++ wget -m -nd -q -c
ftp://sunsite.mff.cuni.cz/MIRRORS/fedora.redhat.com/linux/releases/7/Live/i386/
++ ls --color=tty -l .listing
-rw-r--r-- 1 root root 231 2007-06-19 05:19 .listing
++ wget -m -nd -q -c
ftp://sunsite.mff.cuni.cz/MIRRORS/fedora.redhat.com/linux/releases/7/Live/i386/
++ ls --color=tty -l .listing
-rw-r--r-- 1 root root 462 2007-06-19 05:19 .listing
++ wget -m -nd -q -c
ftp://sunsite.mff.cuni.cz/MIRRORS/fedora.redhat.com/linux/releases/7/Live/i386/
++ ls --color=tty -l .listing
-rw-r--r-- 1 root root 693 2007-06-19 05:19 .listing
++ rpm -Uvh --oldpackage /usr/src/redhat/RPMS/x86_64/wget-1.9.1-22.x86_64.rpm
Preparing...                ########################################### [100%]
   1:wget                   ########################################### [100%]
++ set +x
Comment 10 petrosyan 2008-03-09 14:32:50 EDT
Is this bug still present in Fedora 8?
Comment 11 Karsten Hopp 2008-04-03 10:01:06 EDT
Problem is only reproducable with -c, and it still exists, even with F9's 1.11.1.
Reported upstream...
Comment 12 Karsten Hopp 2008-05-09 07:36:05 EDT
please try wget-1.11.2 which will be in rawhide soon. From the NEWS file:
** Successive invocations of Wget on FTP URLS, with --no-remove-listing
and --continue, was causing Wget to append, rather than replace,
information in the .listing file, and thereby download the same files
multiple times. This has been fixed in 1.11.2.

Note You need to log in before you can comment on or make changes to this bug.