Bug 1799933 - python-graph-tool: FTBFS in Fedora rawhide/f32
Summary: python-graph-tool: FTBFS in Fedora rawhide/f32
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-graph-tool
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ankur Sinha (FranciscoD)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 1841718 (view as bug list)
Depends On:
Blocks: F32FTBFS F33FTBFS F33FailsToInstall F33BetaFreezeException PYTHON39
TreeView+ depends on / blocked
 
Reported: 2020-02-06 19:41 UTC by Fedora Release Engineering
Modified: 2020-09-17 16:00 UTC (History)
5 users (show)

Fixed In Version: python-graph-tool-2.33-1.fc33 python-graph-tool-2.33-1.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-09-10 20:29:11 UTC
Type: ---


Attachments (Terms of Use)
build.log (32.00 KB, text/plain)
2020-02-06 19:41 UTC, Fedora Release Engineering
no flags Details
root.log (32.00 KB, text/plain)
2020-02-06 19:41 UTC, Fedora Release Engineering
no flags Details
state.log (1.00 KB, text/plain)
2020-02-06 19:41 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2020-02-06 19:41:00 UTC
python-graph-tool failed to build from source in Fedora rawhide/f32

https://koji.fedoraproject.org/koji/taskinfo?taskID=41320764


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
Please fix python-graph-tool at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
python-graph-tool will be orphaned. Before branching of Fedora 33,
python-graph-tool will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://fedoraproject.org/wiki/Fails_to_build_from_source

Comment 1 Fedora Release Engineering 2020-02-06 19:41:03 UTC
Created attachment 1660471 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Fedora Release Engineering 2020-02-06 19:41:05 UTC
Created attachment 1660472 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2020-02-06 19:41:06 UTC
Created attachment 1660473 [details]
state.log

Comment 4 Ben Cotton 2020-02-11 16:52:22 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 5 Fedora Release Engineering 2020-02-16 04:29:41 UTC
Dear Maintainer,

your package has not been built successfully in 32. Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. Following the latest policy for such packages [2], your package
will be orphaned if this bug remains in NEW state more than 8 weeks.

A week before the mass branching of Fedora 33 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 31 will be
retired regardless of the status of this bug.

[1] https://fedoraproject.org/wiki/Updates_Policy
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedoraproject.org/wiki/Releases/33/Schedule

Comment 6 Ankur Sinha (FranciscoD) 2020-02-16 13:56:44 UTC
The neuro-sig is working on these bugs.

Comment 7 Miro Hrončok 2020-02-23 13:54:12 UTC
python-graph-tool fails to build with Python 3.9.0a3.

For the build logs, see:
https://copr-be.cloud.fedoraproject.org/results/@python/python3.9/fedora-rawhide-x86_64/01248278-python-graph-tool/

For all our attempts to build python-graph-tool with Python 3.9, see:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/package/python-graph-tool/

Testing and mass rebuild of packages is happening in copr. You can follow these instructions to test locally in mock if your package builds with Python 3.9:
https://copr.fedorainfracloud.org/coprs/g/python/python3.9/

Let us know here if you have any questions.

Python 3.9 will be included in Fedora 33. To make that update smoother, we're building Fedora packages with early pre-releases of Python 3.9.
A build failure prevents us from testing all dependent packages (transitive [Build]Requires), so if this package is required a lot, it's important for us to get it fixed soon.
We'd appreciate help from the people who know this package best, but if you don't want to work on this now, let us know so we can try to work around it on our side.

Comment 8 Miro Hrončok 2020-05-25 13:01:23 UTC
This comment is mass posted to all bugs blocking the Python 3.9 tracker, sorry if it is not 100 % relevant. When in doubt, please ask.


The Python 3.9 rebuild is in progress in a Koji side tag.

If you fix this bug, please don't rebuild the package in regular rawhide, but do it in the side tag with:

    $ fedpkg build --target=f33-python

The rebuild is progressing slowly and it is possible this package won't have all the required build dependencies yet. If that's the case, please just leave the fix committed and pushed and we will eventually rebuild it for you.

You are not asked to go and try rebuild all the missing dependencies yourself. If you know there is a bootstrap loop in the dependencies, let me know and we can untangle it together.

If you want to test your fix or reproduce the failure, you can still use the Copr repo mentioned in the initial comment of this bug: https://copr.fedorainfracloud.org/coprs/g/python/python3.9/

Comment 9 Miro Hrončok 2020-05-29 07:11:26 UTC
Python 3.9 update: The f33-python side tag is currently being merged.

New builds in f33-python are no longer possible, but python3 is not yet updated to Python 3.9 in rawhide. You can check when Python is Python 3.9 with:

    $ koji wait-repo f33-build --build python3.9-3.9.0~b1-3.fc3

And build the packages normally after that.

Comment 10 Miro Hrončok 2020-06-01 12:14:55 UTC
*** Bug 1841718 has been marked as a duplicate of this bug. ***

Comment 11 Miro Hrončok 2020-08-22 10:30:44 UTC
Hello. This comment is mass posted to all 16 bugzillas for packages that failed to rebuild with Python 3.9 (and, in most cases, also fail to install on Fedora 33 and 34). Apologies if some of the suggestions or questions don't apply 100%.

Fedora 33 Beta Freeze starts next week on Tuesday, 2020-08-25. I haven't spammed this bugzilla because it is in ASSIGNED, or I've seen upstream has been notified.

Please consider what to do here. Is this failure critical? For example, can a test be temporarily skipped to make this package build? Is it possible to fix or workaround the failure before Fedora 33 Beta? Or before Fedora 33 Final? If not, would it make sense to retire the package (even temporarily) before the release to unblock updates from Fedora 31 or Fedora 32?

In case you need any assistance with a Python-related problem with the build, don't hesitate to let me know and I'll try to have a look.

Thank you!

Comment 12 Ankur Sinha (FranciscoD) 2020-09-08 07:42:22 UTC
It's built on F34 and F33, bulding on F32 now. Will update in a few days when the build finishes.

Comment 13 Fedora Update System 2020-09-08 19:17:16 UTC
FEDORA-2020-d5184b440d has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-d5184b440d

Comment 14 Fedora Blocker Bugs Application 2020-09-08 21:13:13 UTC
Proposed as a Freeze Exception for 33-beta by Fedora user churchyard using the blocker tracking app because:

 Proposing this existing update as freeze exception. The package won't even install without it.

Comment 15 Fedora Update System 2020-09-08 21:14:07 UTC
FEDORA-2020-d691addd3d has been submitted as an update to Fedora 33. https://bodhi.fedoraproject.org/updates/FEDORA-2020-d691addd3d

Comment 16 Fedora Update System 2020-09-09 14:13:56 UTC
FEDORA-2020-d5184b440d has been pushed to the Fedora 32 testing repository.
In short time you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2020-d5184b440d`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-d5184b440d

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 17 Adam Williamson 2020-09-09 18:26:16 UTC
We have +3 FE in the ticket - https://pagure.io/fedora-qa/blocker-review/issue/70 - so marking as accepted FE. We do typically take FTBFS fixes as FEs.

Comment 18 Fedora Update System 2020-09-10 20:29:11 UTC
FEDORA-2020-d691addd3d has been pushed to the Fedora 33 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 19 Fedora Update System 2020-09-17 16:00:43 UTC
FEDORA-2020-d5184b440d has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.