Bug 180 - Kernels newer then 2.1.X don't work with the DHCP network.
Kernels newer then 2.1.X don't work with the DHCP network.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: dhcp (Show other bugs)
5.2
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Preston Brown
:
: 744 976 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-11-24 04:50 EST by sdeutsch
Modified: 2014-03-19 07:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-02-10 16:36:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sdeutsch 1998-11-24 04:50:33 EST
DHCP client is feeding invalid data to the ifconfig.
IFCONFIG returns with in /var/messages:

Nov 23 19:59:52 beowulf69 dhcpcd[524]: ioctl SIOCSIFBRDADDR
(ifConfig): Cannot assign requested address

and the networks scripts list the device as failing to
start.
Comment 1 sdeutsch 1998-11-30 19:51:59 EST
FIX: Use dhcpcd 1.3.X from ftp://phystech.dyn.ml.org/pub/

It is written to work on the 2.1.X Kernels.....
Comment 2 Jeff Johnson 1999-01-12 06:36:59 EST
*** Bug 180 has been marked as a duplicate of this bug. ***

I'm using Rh 5.2 and am planning to go to 2.2.0 very soon.
One of the packages I've had to update is the dhcp client.
ISC.ORG's client compiles better than the existing source
RPM with the new library.  The reason for this is the change
to the way an ethernet interface is configure in the 2.1.xxx
and 2.2.xxx series.

Do you have an update to the existing package coming up?
Comment 3 David Lawrence 1999-02-06 20:01:59 EST
*** Bug 976 has been marked as a duplicate of this bug. ***

dhcpcd does not work with kernel 2.2 (and 2.1.1xx)

------- Additional Comments From ayn2@cornell.edu  01/29/99 03:06 -------
This is a duplicate of #180
Comment 4 Preston Brown 1999-02-10 16:36:59 EST
there is a newer dhcp in rawhide which works with 2.2.

Note You need to log in before you can comment on or make changes to this bug.