Bug 18001 - Kernels do not compile-- Checksum.S
Kernels do not compile-- Checksum.S
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
: 17999 18000 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-01 02:37 EDT by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-01 02:37:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-10-01 02:37:08 EDT
As an example, Checksum.S and components containing bits of ASM code seem
not to compile with EGCS/GCC 2.96 experimental. I don't know if this
problem is with my system or not (I've installed only RH7.0 components and
all that are necessary; I'm definitely using the GLIBC and the STD libs
from the RH7 package).

I have found though, that using an older, say 1.1.2, version of EGCS seems
to work to compile things like Checksum.S in the arch library of the linux
kernel, but it causes more errors in the long run.
Comment 1 Alan Cox 2000-10-01 18:05:50 EDT
The kernel needs to be built with 'kgcc'. The kernel right now contains stuff
that isnt clean enough
to build with the newer compiler. Edit the top kernel makefile and change the
definition of CC
Comment 2 Alan Cox 2000-10-01 18:06:10 EDT
*** Bug 18000 has been marked as a duplicate of this bug. ***
Comment 3 Alan Cox 2000-10-01 18:06:27 EDT
*** Bug 17999 has been marked as a duplicate of this bug. ***
Comment 4 nbalog 2000-10-31 07:08:44 EST
Changng the CC def does not work. It just spawns the compile with a different 
set of errors.
Comment 5 Jakub Jelinek 2000-10-31 07:40:44 EST
Depends on what you have done.
Either set
CC      =$(CROSS_COMPILE)kgcc -D__KERNEL__ -I$(HPATH)
in the toplevel Makefile, or compile with
make CC='kgcc -D__KERNEL__ -I$(HPATH)'
or 2.2.18pre will do it for you.
Or you can apply
http://www.lucon.org/linux/linux-2.2.14-gcc.patch
http://www.lucon.org/linux/linux-2.2.17-library.patch
and gcc 2.96 should build 2.2 kernel (but if you want to be safe, do one of the
former things).

Note You need to log in before you can comment on or make changes to this bug.