Bug 1800695 - Helm Charts filter in the Developer Catalog didn't get applied
Summary: Helm Charts filter in the Developer Catalog didn't get applied
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Abhinandan Das
QA Contact: Ruchir Garg
URL:
Whiteboard:
Depends On: 1797891 1805159 1810481
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-07 17:45 UTC by Samuel Padgett
Modified: 2020-05-04 11:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Version: 4.4.0-0.ci-2020-02-06-162333 Cluster ID: 4dd4683b-9318-45e7-97dd-f7b5f8debf00 Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:72.0) Gecko/20100101 Firefox/72.0
Last Closed: 2020-05-04 11:34:49 UTC
Target Upstream Version:


Attachments (Terms of Use)
Empty state (235.05 KB, image/png)
2020-02-07 17:45 UTC, Samuel Padgett
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:35:16 UTC

Description Samuel Padgett 2020-02-07 17:45:51 UTC
Created attachment 1661774 [details]
Empty state

Description of problem:

Clicking of the Helm Charts faceted filter in the Developer Catalog did not show me the Helm chart. (See screenshot.)

How reproducible:

Always

Steps to Reproduce:
1. Go to Developer perspective
2. Click Add
3. Select a project if necessary
4. Select From Catalog
5. Click the Helm Charts filter

Actual results:

I see an empty state in the catalog even though there is (1) Helm Chart.

Expected results:

I see the chart.

Comment 1 cvogt 2020-02-07 19:32:16 UTC
Related to https://bugzilla.redhat.com/show_bug.cgi?id=1797891.

This occurs because the capability filters are applied as an AND whereas other filters are an OR.

As per UX request, we are going to remove the capability filters altogether. See https://issues.redhat.com/browse/DTUX-272
This should then fix this issue.

Comment 4 errata-xmlrpc 2020-05-04 11:34:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.