Bug 180085 - gdm graphical greeter window does not get initial focus on multihead xinerama systems
Summary: gdm graphical greeter window does not get initial focus on multihead xinerama...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC6Target
TreeView+ depends on / blocked
 
Reported: 2006-02-05 17:16 UTC by Ulrich Drepper
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-08 15:24:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 333658 None None None Never

Description Ulrich Drepper 2006-02-05 17:16:47 UTC
Description of problem:
On my nvidia twinview system (should be the same for other systems as well) the
mouse cursor is placed in the middle when gdm starts up.  But if, as usual, both
screens have the same resolution a decision has to be made which screen to use.
 In my case, the first screen is to the left and gdm decides to place the mouse
cursor on the second screen.

The result is that I cannot just start typing the ID and password because the
input field on screen 0 does not have focus.  I first have to move the mouse to
the first screen (moving just one pixel would be OK) and then start typing.

Version-Release number of selected component (if applicable):
2.13.0.7-1

How reproducible:
always

Steps to Reproduce:
1.set up multiscreen system with screen 0 to the left
2.restart system
3.
  
Actual results:
mouse in the middle but on screen 1

Expected results:
mouse on screen 0

Additional info:
I think, because the screens are in fact not identical, placing the mouse
squarely in the middle of screen 0 is the correct thing to do.  Especially when
bug 180017 is fixed it'll be clear that all screens are working.

Comment 1 Ray Strode [halfline] 2006-08-08 15:24:44 UTC
This actually got fixed a while ago:

* Wed Jul 19 2006 Ray Strode <rstrode@redhat.com> - 1:2.15.6-10
- center cursor on xinerama head (bug 180085)

I'm going to close the bug, but if it's still a problem, please reopen.


Note You need to log in before you can comment on or make changes to this bug.