Bug 1801212 - Error message not showing up when git url validation fails
Summary: Error message not showing up when git url validation fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Jeff Phillips
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1805289
TreeView+ depends on / blocked
 
Reported: 2020-02-10 12:39 UTC by Jeff Phillips
Modified: 2020-07-13 17:14 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1805289 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:14:25 UTC
Target Upstream Version:


Attachments (Terms of Use)
Error message when validation fails (129.87 KB, image/png)
2020-03-10 08:48 UTC, Gajanan More
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4376 0 None closed Bug 1801212: Fix to show error message when URL validation fails 2020-10-19 09:04:01 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:14:49 UTC

Description Jeff Phillips 2020-02-10 12:39:07 UTC
Description of problem:

when git url validation fails, the error message is not displayed.


Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. From the Add page, select `From Git`
2. In the `Git Repo URL` input, enter a URL that goes somewhere invalid

Actual results:

There is no error indicated but `Create` button is disabled

Expected results:

Error message should be displayed under the field if git url validation fails


Additional info:

Comment 1 Gajanan More 2020-03-10 08:48:49 UTC
Created attachment 1668830 [details]
Error message when validation fails

Comment 2 Gajanan More 2020-03-10 08:51:21 UTC
I have validated this bug on 
Build: 4.5.0-0.ci-2020-03-10-023720
Browser: Google Chrome 78.0.3904.108
Marking this bug as verified.

Comment 5 errata-xmlrpc 2020-07-13 17:14:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.