Bug 1805289 - Error message not showing up when git url validation fails
Summary: Error message not showing up when git url validation fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Jeff Phillips
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1801212
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-20 16:02 UTC by Jeff Phillips
Modified: 2020-05-04 11:39 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1801212
Environment:
Last Closed: 2020-05-04 11:38:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4392 0 None closed [release-4.4] Bug 1805289: Fix to show error message when URL validation fails 2020-04-28 20:21:54 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:39:08 UTC

Description Jeff Phillips 2020-02-20 16:02:11 UTC
+++ This bug was initially created as a clone of Bug #1801212 +++

Description of problem:

when git url validation fails, the error message is not displayed.


Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. From the Add page, select `From Git`
2. In the `Git Repo URL` input, enter a URL that goes somewhere invalid

Actual results:

There is no error indicated but `Create` button is disabled

Expected results:

Error message should be displayed under the field if git url validation fails


Additional info:

Comment 3 Gajanan More 2020-03-03 09:42:15 UTC
The validation has been done on
Build: 4.4.0-0.ci-2020-03-03-033811
Browser: Google Chrome Version 78.0.3904.108

Marking this as done.

Comment 5 errata-xmlrpc 2020-05-04 11:38:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.