Bug 1801256 - ROKS: cloud credential operator is not getting excluded by CVO
Summary: ROKS: cloud credential operator is not getting excluded by CVO
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Credential Operator
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Cesar Wong
QA Contact: wang lin
URL:
Whiteboard: IBMROKS
Depends On:
Blocks: 1801261
TreeView+ depends on / blocked
 
Reported: 2020-02-10 14:21 UTC by Cesar Wong
Modified: 2020-05-13 21:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1801261 (view as bug list)
Environment:
Last Closed: 2020-05-13 21:57:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cloud-credential-operator pull 151 0 None closed Fix exclusion annotation for hosted use case 2020-07-02 03:28:08 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:57:30 UTC

Description Cesar Wong 2020-02-10 14:21:49 UTC
Description of problem:

On a ROKS installation the cloud credential operator still shows up as an available operator.

Steps to Reproduce:
1. Perform an IBM ROKS installation. Check that the cloud credential operator is not present.

Actual results:
CCO is present

Expected results:
CCO is not installed.

Additional info:

Comment 1 Cesar Wong 2020-02-10 14:26:04 UTC
The fix in https://github.com/openshift/cloud-credential-operator/pull/151 does fix the issue.

Comment 3 wang lin 2020-02-12 08:24:28 UTC
Have verified.
The test payload:release:4.4.0-0.nightly-2020-02-11-200858

Comment 5 errata-xmlrpc 2020-05-13 21:57:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.