Bug 1801261 - ROKS: cloud credential operator is not getting excluded by CVO [4.3]
Summary: ROKS: cloud credential operator is not getting excluded by CVO [4.3]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Credential Operator
Version: 4.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.3.z
Assignee: Cesar Wong
QA Contact: wang lin
URL:
Whiteboard: IBMROKS
Depends On: 1801256
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-10 14:28 UTC by Cesar Wong
Modified: 2020-03-24 14:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1801256
Environment:
Last Closed: 2020-03-24 14:33:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cloud-credential-operator pull 156 None closed Bug 1801261: [release-4.3] Fix exclusion annotation for hosted use case 2020-03-23 08:18:05 UTC
Red Hat Product Errata RHBA-2020:0858 None None None 2020-03-24 14:33:30 UTC

Description Cesar Wong 2020-02-10 14:28:43 UTC
+++ This bug was initially created as a clone of Bug #1801256 +++

Description of problem:

On a ROKS installation the cloud credential operator still shows up as an available operator.

Steps to Reproduce:
1. Perform an IBM ROKS installation. Check that the cloud credential operator is not present.

Actual results:
CCO is present

Expected results:
CCO is not installed.

Additional info:

--- Additional comment from Cesar Wong on 2020-02-10 14:26:04 UTC ---

The fix in https://github.com/openshift/cloud-credential-operator/pull/151 does fix the issue.

Comment 3 wang lin 2020-03-10 03:11:03 UTC
test payload:4.3.0-0.nightly-2020-03-09-200240
cloud credential operator can work well on OCP

Comment 5 errata-xmlrpc 2020-03-24 14:33:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0858


Note You need to log in before you can comment on or make changes to this bug.