Bug 180126 - Boot Xen0 need pci=noacpi as kernel paramter
Boot Xen0 need pci=noacpi as kernel paramter
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Juan Quintela
Brian Brock
:
: 180127 180128 180129 180130 180131 180132 180133 180134 180135 (view as bug list)
Depends On:
Blocks: 179599
  Show dependency treegraph
 
Reported: 2006-02-06 03:42 EST by You, Yongkang
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-10 11:56:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The serial output of Xen0 boot fail. (15.10 KB, text/plain)
2006-02-08 04:36 EST, You, Yongkang
no flags Details

  None (edit)
Description You, Yongkang 2006-02-06 03:42:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; Maxthon; .NET CLR 1.1.4322)

Description of problem:
In order to boot up IA32 Xen0, I have to add pci=noacpi as the boot 
parameters of Xen0 kernel, or system will hang when initial PCI.

My test machine mainboard is Intel 915.
It can support x86 and x86-64 modes.
Its BIOS firmware ID is:
VVTGDI6A.86A.8039.2005.0516.0949

Its CPU is HT enabled. 
Processor serial: 0000-0F46-0000-0000-0000-0000

# cat /proc/cpuinfo
vendor_id       : GenuineIntel
cpu family      : 15
model           : 4
model name      : Genuine Intel(R) CPU 3.80GHz
stepping        : 6
cpu MHz         : 3793.088
cache size      : 2048 KB
fdiv_bug        : no
hlt_bug         : yes
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu tsc msr pae mce cx8 apic mtrr mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc pni monitor ds_cpl vmx est tm2 cid cx16 xtpr lahf_lm
bogomips        : 9490.72


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC5-Test2
2. Install Xen RPMs
3. Reboot Machine and select to Xen.

Actual Results:  If not give extra pci=noacpi, xen0 boot will hang at initial PCI. And after give pci=noacpi, Xen0 can boot up.

Additional info:
Comment 1 Ignacio Vazquez-Abrams 2006-02-06 03:47:21 EST
*** Bug 180127 has been marked as a duplicate of this bug. ***
Comment 2 Ignacio Vazquez-Abrams 2006-02-06 03:47:47 EST
*** Bug 180129 has been marked as a duplicate of this bug. ***
Comment 3 Ignacio Vazquez-Abrams 2006-02-06 03:47:49 EST
*** Bug 180128 has been marked as a duplicate of this bug. ***
Comment 4 Ignacio Vazquez-Abrams 2006-02-06 03:48:03 EST
*** Bug 180131 has been marked as a duplicate of this bug. ***
Comment 5 Ignacio Vazquez-Abrams 2006-02-06 03:49:01 EST
*** Bug 180132 has been marked as a duplicate of this bug. ***
Comment 6 Ignacio Vazquez-Abrams 2006-02-06 03:49:04 EST
*** Bug 180130 has been marked as a duplicate of this bug. ***
Comment 7 Ignacio Vazquez-Abrams 2006-02-06 03:49:17 EST
*** Bug 180133 has been marked as a duplicate of this bug. ***
Comment 8 Ignacio Vazquez-Abrams 2006-02-06 03:49:38 EST
*** Bug 180134 has been marked as a duplicate of this bug. ***
Comment 9 Ignacio Vazquez-Abrams 2006-02-06 03:50:16 EST
*** Bug 180135 has been marked as a duplicate of this bug. ***
Comment 10 You, Yongkang 2006-02-06 03:57:10 EST
Ohooo. I am awfully sorry to create so many duplicated same bugs. I suspect my 
web browser (Maxthon) has something wrong to deal with pop-uped window when I 
hit submit button. Then bugs' number kept growing. :( When I notice the 
duplicated bugs, it is too later to close the browser. 

Sincerely sorry again. :(
Comment 11 Stephen Tweedie 2006-02-06 16:14:58 EST
Which exact version of the kernel-xen rpms?  Is it possible for you to include
boot logs (serial console is the best way to capture this) showing both the
successful and unsuccessful boot cases?  Thanks.
Comment 12 You, Yongkang 2006-02-07 01:01:18 EST
I just use the RPM from FC5-test2 CD. It is kernel-xen-hypervisor-2.6.15-
1.29_FC5.i686.rpm

The full serial port output is long. I just paste the contents at the failed 
position. Need I post more info? 

I add pci=noacpi as the kernel parameter to Xen0 kernel line, like:

kernel ...
module /boot/vmlinuz-2.6.15-1.29_FC5hypervisor ro root=dev/sda1 console=tty0 
console=ttyS0 pci=noacpi
module ...

===The serial output when not giving pci=noacpi===
...
ACPI: bus type pci registered
PCI: Using MMCONFIG
ACPI: Subsystem revision 20050902
ACPI: Interpreter enabled
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI: Ignoring BAR0-3 of IDE controller 0000:00:1f.1
PCI: Transparent bridge - 0000:00:1e.0
ACPI: Power Resource [URP1] (off)
ACPI: Power Resource [FDDP] (off)
ACPI: Power Resource [LPTP] (off)
ACPI: Power Resource [URP2] (off)
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 9 10 *11 12 14 15)
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 9 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 *5 6 7 9 10 11 12 14 15)
ACPI: PC

==================

===The serial output when giving pci=noacpi===
...
ACPI: bus type pci registered
PCI: Using MMCONFIG
ACPI: Subsystem revision 20050902
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: Power Resource [URP1] (off)
ACPI: Power Resource [FDDP] (off)
ACPI: Power Resource [LPTP] (off)
ACPI: Power Resource [URP2] (off)
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
pnp: PnP ACPI: found 13 devices
xen_mem: Initialising balloon driver.
usbcore: registered new driver usbfs
usbcore: registered new driver hub
PCI: Probing PCI hardware
PCI: Ignoring BAR0-3 of IDE controller 0000:00:1f.1
PCI: Transparent bridge - 0000:00:1e.0
PCI: Using IRQ router PIIX/ICH [8086/2640] at 0000:00:1f.0
PCI->APIC IRQ transform: 0000:00:02.0[A] -> IRQ 16
PCI->APIC IRQ transform: 0000:00:1b.0[A] -> IRQ 16
PCI->APIC IRQ transform: 0000:00:1d.0[A] -> IRQ 23
PCI->APIC IRQ transform: 0000:00:1d.1[B] -> IRQ 19
PCI->APIC IRQ transform: 0000:00:1d.2[C] -> IRQ 18
PCI->APIC IRQ transform: 0000:00:1d.3[D] -> IRQ 16
PCI->APIC IRQ transform: 0000:00:1d.7[A] -> IRQ 23
PCI->APIC IRQ transform: 0000:00:1f.1[A] -> IRQ 18
PCI->APIC IRQ transform: 0000:00:1f.2[B] -> IRQ 19
PCI->APIC IRQ transform: 0000:00:1f.3[B] -> IRQ 19
PCI->APIC IRQ transform: 0000:06:01.0[A] -> IRQ 22
PCI->APIC IRQ transform: 0000:06:08.0[A] -> IRQ 20
pnp: 00:0a: ioport range 0x400-0x47f could not be reserved
pnp: 00:0a: ioport range 0x680-0x6ff has been reserved
pnp: 00:0a: ioport range 0x500-0x53f has been reserved
PCI: Ignore bogus resource 6 [0:0] of 0000:00:02.0
PCI: Bridge: 0000:00:01.0
  IO window: disabled.
  MEM window: ffa00000-ffafffff
  PREFETCH window: aff00000-afffffff
PCI: Bridge: 0000:00:1c.0
  IO window: disabled.
  MEM window: ff600000-ff6fffff
  PREFETCH window: afb00000-afbfffff
PCI: Bridge: 0000:00:1c.1
  IO window: disabled.
  MEM window: ff700000-ff7fffff
  PREFETCH window: afc00000-afcfffff
PCI: Bridge: 0000:00:1c.2
  IO window: disabled.
  MEM window: ff800000-ff8fffff
  PREFETCH window: afd00000-afdfffff
PCI: Bridge: 0000:00:1c.3
  IO window: disabled.
  MEM window: ff900000-ff9fffff
  PREFETCH window: afe00000-afefffff
PCI: Bridge: 0000:00:1e.0
  IO window: b000-bfff
  MEM window: ff500000-ff5fffff
  PREFETCH window: afa00000-afafffff
PCI: No IRQ known for interrupt pin A of device 0000:00:01.0. Probably buggy 
MP table.
PCI: No IRQ known for interrupt pin A of device 0000:00:1c.0. Probably buggy 
MP table.
PCI: No IRQ known for interrupt pin B of device 0000:00:1c.1. Probably buggy 
MP table.
PCI: No IRQ known for interrupt pin C of device 0000:00:1c.2. Probably buggy 
MP table.
PCI: No IRQ known for interrupt pin D of device 0000:00:1c.3. Probably buggy 
MP table.
IA-32 Microcode Update Driver: v1.14-xen <tigran@veritas.com>
audit: initializing netlink socket (disabled)
audit(1139319661.700:1): initialized
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
SELinux:  Registering netfilter hooks
Initializing Cryptographic API
ksign: Installing public key data
Loading keyring
- Added public key 8937C79E295E08A
- User ID: Red Hat, Inc. (Kernel Module GPG key)
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered
PCI: No IRQ known for interrupt pin A of device 0000:00:01.0. Probably buggy 
MP table.
pcie_portdrv_probe->Dev[2581:8086] has invalid IRQ. Check vendor BIOS
assign_interrupt_mode Found MSI capability
PCI: No IRQ known for interrupt pin A of device 0000:00:1c.0. Probably buggy 
MP table.
pcie_portdrv_probe->Dev[2660:8086] has invalid IRQ. Check vendor BIOS
assign_interrupt_mode Found MSI capability
PCI: No IRQ known for interrupt pin B of device 0000:00:1c.1. Probably buggy 
MP table.
pcie_portdrv_probe->Dev[2662:8086] has invalid IRQ. Check vendor BIOS
assign_interrupt_mode Found MSI capability
PCI: No IRQ known for interrupt pin C of device 0000:00:1c.2. Probably buggy 
MP table.
pcie_portdrv_probe->Dev[2664:8086] has invalid IRQ. Check vendor BIOS
assign_interrupt_mode Found MSI capability
PCI: No IRQ known for interrupt pin D of device 0000:00:1c.3. Probably buggy 
MP table.
pcie_portdrv_probe->Dev[2666:8086] has invalid IRQ. Check vendor BIOS
assign_interrupt_mode Found MSI capability
ACPI: Processor [CPU1] (supports 8 throttling states)
ACPI: Processor [CPU2] (supports 8 throttling states)
Real Time Clock Driver v1.12
Linux agpgart interface v0.101 (c) Dave Jones
agpgart: Detected an Intel 915G Chipset.
agpgart: Detected 7932K stolen memory.
agpgart: AGP aperture is 256M @ 0xb0000000
PNP: No PS/2 controller found. Probing ports directly.
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
RAMDISK driver initialized: 16 RAM disks of 16384K size 1024 blocksize
Xen virtual console successfully installed as ttyS0
Event-channel device installed.
blkif_init: reqs=64, pages=704, mmap_vstart=0xcfc00000
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ICH6: IDE controller at PCI slot 0000:00:1f.1
ICH6: chipset revision 4
ICH6: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xffa0-0xffa7, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xffa8-0xffaf, BIOS settings: hdc:pio, hdd:pio
hda: TEAC DW-552G, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hda: ATAPI 52X DVD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
ide-floppy driver 0.99.newide
usbcore: registered new driver libusual
usbcore: registered new driver hiddev
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.6:USB HID core driver
mice: PS/2 mouse device common for all mice
md: md driver 0.90.3 MAX_MD_DEVS=256, MD_SB_DISKS=27
md: bitmap version 4.39
NET: Registered protocol family 2
IP route cache hash table entries: 4096 (order: 2, 16384 bytes)
TCP established hash table entries: 16384 (order: 6, 327680 bytes)
TCP bind hash table entries: 16384 (order: 6, 327680 bytes)
TCP: Hash tables configured (established 16384 bind 16384)
TCP reno registered
TCP bic registered
Initializing IPsec netlink socket
NET: Registered protocol family 1
NET: Registered protocol family 17
Using IPI No-Shortcut mode
Freeing unused kernel memory: 176k freed
Red Hat nash version 5.0.17 starting
Mounting proc filesystem
Mounting sysfs filesystem
Creating /dev
Creating initial device nodes
Setting up hotplug.
Creating block device nodes.
Loading scsi_mod.ko module
SCSI subsystem initialized
Loading sd_mod.ko module
Loading libata.ko module
Loading ata_piix.ko module
ata1: SATA max UDMA/133 cmd 0xE800 ctl 0xE402 bmdma 0xD800 irq 19
ata2: SATA max UDMA/133 cmd 0xE000 ctl 0xDC02 bmdma 0xD808 irq 19
ata1: dev 0 ATA-6, max UDMA/133, 234441648 sectors: LBA48
ata1: dev 0 configured for UDMA/133
scsi0 : ata_piix
ATA: abnormal status 0x7F on port 0xE007
ata2: disabling port
scsi1 : ata_piix
  Vendor: ATA       Model: ST3120026AS       Rev: 3.00
  Type:   Direct-Access                      ANSI SCSI revision: 05
SCSI device sda: 234441648 512-byte hdwr sectors (120034 MB)
SCSI device sda: drive cache: write back
SCSI device sda: 234441648 512-byte hdwr sectors (120034 MB)
SCSI device sda: drive cache: write back
 sda: sda1 sda2 sda3 sda4 < sda5 sda6 sda7 sda8 >
sd 0:0:0:0: Attached scsi disk sda
Loading jbd.ko module
Loading ext3.ko module
Creating root device.
Mounting root filesystem.
EXT3-fs: INFO: recovery required on readonly filesystem.
EXT3-fs: write access will be enabled during recovery.
kjournald starting.  Commit interval 5 seconds
EXT3-fs: recovery complete.
EXT3-fs: mounted filesystem with ordered data mode.
Setting up other filesystems.
Setting up new root fs
no fstab.sys, mounting internal defaults
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
SELinux:  Disabled at runtime.
SELinux:  Unregistering netfilter hooks
...

========END=======
Comment 13 Stephen Tweedie 2006-02-07 07:59:29 EST
The first boot log looks like it has been partially eaten.  Incomplete logs like
that sometimes result from async serial console; are you already using
sync_console?  If not, please recapture with "sync_console" appended to the
hypervisor options.

Also, please supply large logs like this as bugzilla attachments, rather than
pasting them inline -- it is much easier to extraxt them and it doesn't clutter
the text.  

Finally, the latest rawhide includes kernel-xen-2.6.15-1.40_FC5.  That includes
a recent update from Dave Jones' main rawhide kernel which pulled in a large set
of ACPI changes; could you please test to see if those help at all?

Thanks!
Comment 14 You, Yongkang 2006-02-08 04:32:08 EST
We have retested this issue with both FC5-t2 RPM and the kernel-xen-2.6.15-
1.40_FC5. We have a new find.

If we don't provide serial output config as kernel parameter (it means we 
don't need serial port to see boot process.), Domain0 can boot up successfully.

If we give serial config to the kernel, we have to add pci=noacpi to enable 
Domain0 boot. Or Domain0 booting process will stop at the same position.

The grub config is like:
title Fedora Core (2.6.15-1.29_FC5hypervisor)
        root (hd0,0)
        kernel /boot/xen.gz-2.6.15-1.29_FC5 com1=115200,8n1
        module /boot/vmlinuz-2.6.15-1.29_FC5hypervisor ro root=/dev/sda1 
console=tty0 console=ttyS0 sync_console
        module /boot/initrd-2.6.15-1.29_FC5hypervisor.img

Any comments? Is there any problem about enabling serial output? Or the 
setting is not correct? I use the similar setting for a long time.

I will add the serial log to the attachment.
Comment 15 You, Yongkang 2006-02-08 04:36:17 EST
Created attachment 124367 [details]
The serial output of Xen0 boot fail.

Xen0 boot fail with serial port enabled.
I add "sync_console" appended to kernel, serial output info seemed hasn't more
contents.
Comment 16 Paul Jakma 2006-02-08 05:49:41 EST
I see this too. It's some kind of problem with Xen hypervisor serial console
*and* xencons. Because either of following allows Linux xen0 to boot:

a) Do not configure Xen hypervisor for serial output

or

b) Configure Xen for serial console but pass xencons=off to the linux xen0
kernel commandline.

I havn't tried pci=noacpi yet.
Comment 17 Paul Jakma 2006-02-09 18:39:13 EST
Serial console in xen and Linux output to xencons (hence serial) works here with
pci=noacpi.
Comment 18 Jeremy Katz 2006-02-24 13:18:41 EST
Is this better with test3?
Comment 19 Paul Jakma 2006-02-24 20:54:18 EST
Nope, it's much worse. 

Now the pci=noacpi trick no longer works with the 2.6.15-1.1977 hypervisor and
dom0. It hangs as the dom0 linux kernel starts printing out ACPI configuration.

I'll try get boot log with Xen configured for unbuffered serial output.
Comment 20 You, Yongkang 2006-02-25 21:45:39 EST
As my experience, in test3 except add pci=noacpi as Dom0 kernel parameter, it 
need add acpi=off as xen.gz kernel parameter. 

I give an workable example for grub.conf in bug #182722
Comment 21 Stephen Tweedie 2006-03-09 12:05:33 EST
I've seen such hangs before too, but only when using async console: sync_console
fixed it for me.

I just noticed from a previous comment:

        kernel /boot/xen.gz-2.6.15-1.29_FC5 com1=115200,8n1
        module /boot/vmlinuz-2.6.15-1.29_FC5hypervisor ro root=/dev/sda1 
console=tty0 console=ttyS0 sync_console

This is wrong, the "sync_console" needs to be on the "kernel" hypervisor option
list, not the xen0 module list.  Can you reproduce with that change? 

Thanks,
 Stephen
Comment 22 You, Yongkang 2006-03-09 20:21:33 EST
This issue disappeared with following config.

        kernel /boot/xen.gz-2.6.15-1.29_FC5 com1=115200,8n1 sync_console
        module /boot/vmlinuz-2.6.15-1.29_FC5hypervisor ro root=/dev/sda1 
console=tty0 console=ttyS0 

It is a little strange, that we didn't use "sync_console" in Xen befero. :)
Maybe this specail config item should be add into something like readme in
Fedora Xen, because Xen manual didn't mention it, user may meet the same trouble
like me.
Comment 23 You, Yongkang 2006-03-10 04:53:06 EST
With above config, I can get Xen0 start and serial output information. But I can
not input any commands from serial console after Xen begin to boot. I have given
the correct setting in Xen0 inittab. Can you input anything in serial console to
control Xen? Is there any other configuration?
Comment 24 Stephen Tweedie 2006-03-10 11:56:08 EST
OK, closing this bug: the platform boot issue is resolved.

And yes, adding sync_console as a default is something we need to look at: we're
very much aware of that problem, and of the problem of serial console input
being broken on SMP.  (The latter problem affects main XenSource kernels too;
the former does not, probably due to a config difference between our builds.)

Note You need to log in before you can comment on or make changes to this bug.