Bug 1801315 - The program "systemd-tty-ask-password-agent" is missing in the generated initramfs
Summary: The program "systemd-tty-ask-password-agent" is missing in the generated init...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: 32
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: dracut-maint-list
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1809722 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-10 16:03 UTC by Villy Kruse
Modified: 2020-03-24 20:39 UTC (History)
5 users (show)

Fixed In Version: dracut-050-26.git20200316.fc32
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-24 20:39:50 UTC
Type: Bug


Attachments (Terms of Use)

Description Villy Kruse 2020-02-10 16:03:33 UTC
Description of problem:

The services systemd-ask-password-console.service and systemd-ask-password-plymouth.service have the entry "ExecStart=/usr/bin/systemd-tty-ask-password-agent".

The program "systemd-tty-ask-password-agent" is not included in the generated initramfs.  This was also the case with Fedora 31, but the new systemd version in Fedora 32 has started complaining about that.

Comment 1 Ben Cotton 2020-02-11 16:33:09 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 32 development cycle.
Changing version to 32.

Comment 2 Andrey Motoshkov 2020-02-16 10:04:36 UTC
Have below in log:
[    3.900899] systemd[1]: systemd v245~rc1-2.fc32 running in system mode. (+PAM +AUDIT +SELINUX +IMA -APPARMOR +SMACK +SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD +IDN2 -IDN +PCRE2 default-hierarchy=unified)
[    3.914006] systemd[1]: Detected architecture x86-64.
[    3.914020] systemd[1]: Running in initial RAM disk.
[    3.914193] systemd[1]: Set hostname to <removed>.
[    4.000356] systemd[1]: initrd.target: Requested dependency OnFailure=emergency.target ignored (target units cannot fail).
[    4.004859] systemd[1]: /usr/lib/systemd/system/systemd-ask-password-console.service:12: Executable "systemd-tty-ask-password-agent" not found in path "/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin"
[    4.004863] systemd[1]: systemd-ask-password-console.service: Unit configuration has fatal error, unit will not be started.
[    4.007951] systemd[1]: local-fs.target: Requested dependency OnFailure=emergency.target ignored (target units cannot fail).
[    4.013102] systemd[1]: initrd-fs.target: Requested dependency OnFailure=emergency.target ignored (target units cannot fail).
[    4.013239] systemd[1]: initrd-root-device.target: Requested dependency OnFailure=emergency.target ignored (target units cannot fail).
[    4.013514] systemd[1]: initrd-root-fs.target: Requested dependency OnFailure=emergency.target ignored (target units cannot fail).

Comment 3 Villy Kruse 2020-02-16 16:05:43 UTC
If you have a system with luks encrypted file systems the file /usr/bin/systemd-tty-ask-password-agent will be included in the initrd file.

Comment 4 Andrey Motoshkov 2020-02-18 10:15:08 UTC
(In reply to Villy Kruse from comment #3)
> If you have a system with luks encrypted file systems the file
> /usr/bin/systemd-tty-ask-password-agent will be included in the initrd file.

I have luks encrypted fs but this file is not included:
$ cat /etc/fstab | grep luks
/dev/mapper/luks-78a6657f-6a60-4d50-9118-393169f019a7 /home                   ext4    defaults,x-systemd.device-timeout=0 1 2

$ lsinitrd /boot/initramfs-5.6.0-0.rc1.git2.1.fc32.x86_64.img | grep ask-password
lrwxrwxrwx   1 root     root           36 Jan 28 18:17 usr/lib/systemd/system/sysinit.target.wants/systemd-ask-password-console.path -> ../systemd-ask-password-console.path
-rw-r--r--   1 root     root          722 Jan 28 18:17 usr/lib/systemd/system/systemd-ask-password-console.path
-rw-r--r--   1 root     root          737 Jan 28 18:17 usr/lib/systemd/system/systemd-ask-password-console.service
drwxr-xr-x   2 root     root            0 Jan 28 18:17 usr/lib/systemd/system/systemd-ask-password-console.service.wants
lrwxrwxrwx   1 root     root           33 Jan 28 18:17 usr/lib/systemd/system/systemd-ask-password-console.service.wants/systemd-vconsole-setup.service -> ../systemd-vconsole-setup.service
-rw-r--r--   1 root     root          454 Jan 28 18:17 usr/lib/systemd/system/systemd-ask-password-plymouth.path
-rw-r--r--   1 root     root          435 Jan 28 18:17 usr/lib/systemd/system/systemd-ask-password-plymouth.service
drwxr-xr-x   2 root     root            0 Jan 28 18:17 usr/lib/systemd/system/systemd-ask-password-plymouth.service.wants
lrwxrwxrwx   1 root     root           33 Jan 28 18:17 usr/lib/systemd/system/systemd-ask-password-plymouth.service.wants/systemd-vconsole-setup.service -> ../systemd-vconsole-setup.service

Comment 5 Villy Kruse 2020-02-18 17:38:36 UTC
(In reply to Andrey Motoshkov from comment #4)
> (In reply to Villy Kruse from comment #3)
> > If you have a system with luks encrypted file systems the file
> > /usr/bin/systemd-tty-ask-password-agent will be included in the initrd file.
> 
> I have luks encrypted fs but this file is not included:
> $ cat /etc/fstab | grep luks
> /dev/mapper/luks-78a6657f-6a60-4d50-9118-393169f019a7 /home                 
> ext4    defaults,x-systemd.device-timeout=0 1 2
> 
> 


Maybe it will be included i you have a luks encrypted root file system.  I just wanted to mention that under certain conditions, the /usr/bin/systemd-tty-ask-password-agent will be included in initrd and under other conditions it won't.

Comment 6 Zbigniew Jędrzejewski-Szmek 2020-03-03 14:33:11 UTC
This is fixed upstream by https://github.com/dracutdevs/dracut/commit/16abea2592d7fee6166660098b647356d5a4cc14.

Comment 7 Zbigniew Jędrzejewski-Szmek 2020-03-03 19:16:39 UTC
*** Bug 1809722 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2020-03-04 20:15:18 UTC
dracut-050-1.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-e8ed29f8bc

Comment 9 Fedora Update System 2020-03-11 14:05:24 UTC
FEDORA-2020-529e8e2f53 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-529e8e2f53

Comment 10 Fedora Update System 2020-03-12 18:49:40 UTC
dracut-050-2.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-529e8e2f53

Comment 11 Fedora Update System 2020-03-13 15:11:35 UTC
FEDORA-2020-529e8e2f53 has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-529e8e2f53

Comment 12 Fedora Update System 2020-03-13 18:33:20 UTC
dracut-050-25.git20200313.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-529e8e2f53

Comment 13 Fedora Update System 2020-03-16 15:46:53 UTC
FEDORA-2020-c7a820c8ab has been submitted as an update to Fedora 32. https://bodhi.fedoraproject.org/updates/FEDORA-2020-c7a820c8ab

Comment 14 Fedora Update System 2020-03-17 02:48:55 UTC
dracut-050-26.git20200316.fc32 has been pushed to the Fedora 32 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2020-c7a820c8ab

Comment 15 Fedora Update System 2020-03-24 20:39:50 UTC
FEDORA-2020-c7a820c8ab has been pushed to the Fedora 32 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.