Bug 1809722 - systemd-tty-ask-password-agent not found during boot sequence
Summary: systemd-tty-ask-password-agent not found during boot sequence
Keywords:
Status: CLOSED DUPLICATE of bug 1801315
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: 32
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-03 18:25 UTC by Baptiste Mille-Mathias
Modified: 2020-03-03 19:16 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-03-03 19:16:39 UTC
Type: Bug


Attachments (Terms of Use)

Description Baptiste Mille-Mathias 2020-03-03 18:25:55 UTC
Description of problem:
I'm debugging a problem since I switch to f32 that prevent a mount to be done during the boot, and during investigation I came across this message.


Mar 03 18:49:43 ivy systemd[1]: initrd.target: Requested dependency OnFailure=emergency.target ignored (target units cannot fail).
Mar 03 18:49:43 ivy systemd[1]: /usr/lib/systemd/system/systemd-ask-password-console.service:12: Executable "systemd-tty-ask-password-agent" not found in path "/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin"
Mar 03 18:49:43 ivy systemd[1]: systemd-ask-password-console.service: Unit configuration has fatal error, unit will not be started.
Mar 03 18:49:43 ivy systemd[1]: local-fs.target: Requested dependency OnFailure=emergency.target ignored (target units cannot fail).
Mar 03 18:49:43 ivy systemd[1]: initrd-fs.target: Requested dependency OnFailure=emergency.target ignored (target units cannot fail).
Mar 03 18:49:43 ivy systemd[1]: initrd-root-device.target: Requested dependency OnFailure=emergency.target ignored (target units cannot fail).
Mar 03 18:49:43 ivy systemd[1]: initrd-root-fs.target: Requested dependency OnFailure=emergency.target ignored (target units cannot fail).
Mar 03 18:49:43 ivy systemd[1]: Reached target Local File Systems.
...
Mar 03 18:49:44 ivy systemd[1]: /usr/lib/systemd/system/systemd-ask-password-console.service:12: Executable "systemd-tty-ask-password-agent" not found in path "/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin"
Mar 03 18:49:44 ivy systemd[1]: systemd-ask-password-console.service: Unit configuration has fatal error, unit will not be started.
Mar 03 18:49:44 ivy systemd[1]: initrd.target: Requested dependency OnFailure=emergency.target ignored (target units cannot fail).
Mar 03 18:49:44 ivy systemd[1]: initrd-root-device.target: Requested dependency OnFailure=emergency.target ignored (target units cannot fail).
Mar 03 18:49:44 ivy systemd[1]: initrd-fs.target: Requested dependency OnFailure=emergency.target ignored (target units cannot fail).
Mar 03 18:49:44 ivy systemd[1]: local-fs.target: Requested dependency OnFailure=emergency.target ignored (target units cannot fail).
Mar 03 18:49:44 ivy systemd[1]: initrd-root-fs.target: Requested dependency OnFailure=emergency.target ignored (target units cannot fail).


Version-Release number of selected component (if applicable):
Name        : systemd
Version     : 245~rc1
Release     : 3.fc32

How reproducible:
Don't know

Additional info:
Don't know if this is related to the mount issue I get

Mar 03 18:49:55 ivy kernel: audit: type=1131 audit(1583257795.887:93): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-rfkill comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
Mar 03 18:51:15 ivy systemd[1]: dev-disk-by\x2duuid-24c6beab\x2d3a4d\x2d4b57\x2d8192\x2d5ed5bcacbffe.device: Job dev-disk-by\x2duuid-24c6beab\x2d3a4d\x2d4b57\x2d8192\x2d5ed5bcacbffe.device/start timed out.
Mar 03 18:51:15 ivy systemd[1]: Timed out waiting for device /dev/disk/by-uuid/24c6beab-3a4d-4b57-8192-5ed5bcacbffe.
Mar 03 18:51:15 ivy systemd[1]: Dependency failed for /share.
Mar 03 18:51:15 ivy systemd[1]: Dependency failed for Local File Systems.
Mar 03 18:51:15 ivy systemd[1]: local-fs.target: Job local-fs.target/start failed with result 'dependency'.
Mar 03 18:51:15 ivy systemd[1]: share.mount: Job share.mount/start failed with result 'dependency'.
Mar 03 18:51:15 ivy systemd[1]: Dependency failed for File System Check on /dev/disk/by-uuid/24c6beab-3a4d-4b57-8192-5ed5bcacbffe.
Mar 03 18:51:15 ivy systemd[1]: systemd-fsck@dev-disk-by\x2duuid-24c6beab\x2d3a4d\x2d4b57\x2d8192\x2d5ed5bcacbffe.service: Job systemd-fsck@dev-disk-by\x2duuid-24c6beab\x2d3a4d\x2d4b57\x2d8192\x2d5ed5bcacbffe.service/start failed with result 'dependency'.
Mar 03 18:51:15 ivy systemd[1]: dev-disk-by\x2duuid-24c6beab\x2d3a4d\x2d4b57\x2d8192\x2d5ed5bcacbffe.device: Job dev-disk-by\x2duuid-24c6beab\x2d3a4d\x2d4b57\x2d8192\x2d5ed5bcacbffe.device/start failed with result 'timeout'.

Comment 1 Zbigniew Jędrzejewski-Szmek 2020-03-03 19:16:39 UTC

*** This bug has been marked as a duplicate of bug 1801315 ***


Note You need to log in before you can comment on or make changes to this bug.