Bug 1801358 - Fix Prometheus statefulset crash loop on kubernetes v1.17.0
Summary: Fix Prometheus statefulset crash loop on kubernetes v1.17.0
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Paul Gier
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks: 1801368
TreeView+ depends on / blocked
 
Reported: 2020-02-10 17:44 UTC by Paul Gier
Modified: 2020-05-04 11:35 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1801368 (view as bug list)
Environment:
Last Closed: 2020-05-04 11:35:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-monitoring-operator pull 651 None closed Bug 1801358: update prometheus-operator v0.35.1 2020-07-01 08:53:13 UTC
Github openshift prometheus-operator pull 52 None closed Bug 1801358: Bump v0.35.1 2020-07-01 08:53:13 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:35:55 UTC

Description Paul Gier 2020-02-10 17:44:50 UTC
Description of problem:
Due to an issue in how Kubernetes v0.17.0 validates PVCs (https://github.com/kubernetes/kubernetes/issues/87583), the prometheus operator could not successfully create prometheus stateful sets (https://github.com/coreos/prometheus-operator/issues/2950).

Version-Release number of selected component (if applicable):

Prometheus operator 0.36.0 and earlier.

How reproducible:

Always happens with certain config in kube 0.17.0

Steps to Reproduce:

Create a prometheus custom resource containing a volumeClaimTemplate containing either the apiVersion or Kind fields set to non-null values.

Comment 6 Junqi Zhao 2020-02-14 01:11:17 UTC
tested with 4.4.0-0.nightly-2020-02-13-192852, the Prometheus Operator version is v0.35.1 and the related resources' "app.kubernetes.io/version" according to the fix are v0.35.1

Comment 8 errata-xmlrpc 2020-05-04 11:35:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.