Bug 1801368 - Fix Prometheus statefulset crash loop on kubernetes v1.17.0
Summary: Fix Prometheus statefulset crash loop on kubernetes v1.17.0
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.3.z
Assignee: Paul Gier
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On: 1801358
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-10 18:03 UTC by Paul Gier
Modified: 2020-03-11 07:24 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1801358
Environment:
Last Closed: 2020-03-11 07:24:25 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift prometheus-operator pull 53 0 None closed Bug 1801368: Bump v0.34.1 2020-07-01 08:53:05 UTC

Description Paul Gier 2020-02-10 18:03:32 UTC
+++ This bug was initially created as a clone of Bug #1801358 +++

Description of problem:
Due to an issue in how Kubernetes v0.17.0 validates PVCs (https://github.com/kubernetes/kubernetes/issues/87583), the prometheus operator could not successfully create prometheus stateful sets (https://github.com/coreos/prometheus-operator/issues/2950).

Version-Release number of selected component (if applicable):

Prometheus operator 0.36.0 and earlier.

How reproducible:

Always happens with certain config in kube 0.17.0

Steps to Reproduce:

Create a prometheus custom resource containing a volumeClaimTemplate containing either the apiVersion or Kind fields set to non-null values.


Note You need to log in before you can comment on or make changes to this bug.