Bug 1802300 - Dev-Monitoring: Pre-canned queries need to be updated in monitoring dashboard & metrics tabs
Summary: Dev-Monitoring: Pre-canned queries need to be updated in monitoring dashboard...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.4.0
Assignee: Abhishek K N
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On: 1806518
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-12 20:31 UTC by Abhishek K N
Modified: 2020-05-13 21:57 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1806518 (view as bug list)
Environment:
Last Closed: 2020-05-13 21:57:54 UTC
Target Upstream Version:


Attachments (Terms of Use)
Dev-Monitoring: Pre-canned queries updated in monitoring dashboard & metrics tabs-1 (43.40 KB, image/png)
2020-03-03 16:45 UTC, spathak@redhat.com
no flags Details
Dev-Monitoring: Pre-canned queries updated in monitoring dashboard & metrics tabs-2 (43.92 KB, image/png)
2020-03-03 16:47 UTC, spathak@redhat.com
no flags Details
Dev-Monitoring: Pre-canned queries updated in monitoring dashboard & metrics tabs-3 (35.71 KB, image/png)
2020-03-03 16:47 UTC, spathak@redhat.com
no flags Details
Dev-Monitoring: Pre-canned queries updated in monitoring dashboard & metrics tabs-4 (57.10 KB, image/png)
2020-03-03 16:48 UTC, spathak@redhat.com
no flags Details
Dev-Monitoring: Pre-canned queries updated in monitoring dashboard & metrics tabs-5 (30.55 KB, image/png)
2020-03-03 16:49 UTC, spathak@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4566 None closed [release-4.4] Bug 1802300: Monitoring Dashboard metrics corrections 2020-04-28 19:36:36 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-13 21:57:56 UTC

Description Abhishek K N 2020-02-12 20:31:06 UTC
Description of problem:
Pre-canned queries need to be updated in monitoring dashboard & metrics tabs as per design doc https://docs.google.com/document/d/1xkYXr_RijaXJwN6AdOcQNzJyyydK9RAVBeUvAqtex50/edit?usp=sharing

Version-Release number of selected component (if applicable): 4.4


How reproducible:


Steps to Reproduce:
1. Navigate to Monitoring page under Developer perspective
2. Select Dashboard tab & Metrics tab separately 
3. Validate metrics list displayed on each tab

Actual results:
Network Transfer in/out, Local Storage & Attached Storage are missing under Dashboard tab. Inappropriate friendly names listed for pre-canned queries in metrics tab

Expected results:
In Dashboard tab, Network Transfer in/out, Local Storage & Attached Storage metrics need to displayed in addition to existing list of metrics. Friendly names listed for pre-canned queries in metrics tab need to be corrected with valid names.

Additional info:

Comment 3 Ruchir Garg 2020-03-02 06:38:46 UTC
Bulk assigning all to Gajanan for verification.

Comment 4 spathak@redhat.com 2020-03-03 16:45:43 UTC
Created attachment 1667242 [details]
Dev-Monitoring: Pre-canned queries updated in monitoring dashboard & metrics tabs-1

Comment 5 spathak@redhat.com 2020-03-03 16:47:01 UTC
Created attachment 1667243 [details]
Dev-Monitoring: Pre-canned queries updated in monitoring dashboard & metrics tabs-2

Comment 6 spathak@redhat.com 2020-03-03 16:47:51 UTC
Created attachment 1667244 [details]
Dev-Monitoring: Pre-canned queries updated in monitoring dashboard & metrics tabs-3

Comment 7 spathak@redhat.com 2020-03-03 16:48:45 UTC
Created attachment 1667247 [details]
Dev-Monitoring: Pre-canned queries updated in monitoring dashboard & metrics tabs-4

Comment 8 spathak@redhat.com 2020-03-03 16:49:38 UTC
Created attachment 1667251 [details]
Dev-Monitoring: Pre-canned queries updated in monitoring dashboard & metrics tabs-5

Comment 9 spathak@redhat.com 2020-03-03 16:50:43 UTC
Verified on build : 4.4.0-0.ci-2020-03-03-033811
Chrome browser: 76.0.3809.132

Comment 11 errata-xmlrpc 2020-05-13 21:57:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.