Bug 1806518 - Dev-Monitoring: Pre-canned queries need to be updated in monitoring dashboard & metrics tabs
Summary: Dev-Monitoring: Pre-canned queries need to be updated in monitoring dashboard...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.5.0
Assignee: Abhishek K N
QA Contact: spathak@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1802300
TreeView+ depends on / blocked
 
Reported: 2020-02-24 12:34 UTC by Abhishek K N
Modified: 2020-08-04 18:02 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Metrics queries for Dashboard & Metrics tab got updated in design doc. Consequence: Code need to be synced w.r.t queries / order / labels. Fix: Updated queries Result: Order of the metrics queries & their labels are synced with design.
Clone Of: 1802300
Environment:
Last Closed: 2020-08-04 18:02:02 UTC
Target Upstream Version:


Attachments (Terms of Use)
Dev-Monitoring: Pre-canned queries updated in monitoring dashboard & metrics tabs-1 (43.40 KB, image/png)
2020-03-03 16:34 UTC, spathak@redhat.com
no flags Details
Dev-Monitoring: Pre-canned queries updated in monitoring dashboard & metrics tabs-2 (34.60 KB, image/png)
2020-03-03 16:35 UTC, spathak@redhat.com
no flags Details
Dev-Monitoring: Pre-canned queries updated in monitoring dashboard & metrics tabs-3 (35.71 KB, image/png)
2020-03-03 16:36 UTC, spathak@redhat.com
no flags Details
Dev-Monitoring: Pre-canned queries updated in monitoring dashboard & metrics tabs-4 (57.10 KB, image/png)
2020-03-03 16:37 UTC, spathak@redhat.com
no flags Details
Dev-Monitoring: Pre-canned queries updated in monitoring dashboard & metrics tabs-5 (27.28 KB, image/png)
2020-03-03 16:38 UTC, spathak@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4323 None closed Bug 1806518: Monitoring Dashboard metrics corrections 2020-06-30 19:09:07 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-08-04 18:02:05 UTC

Description Abhishek K N 2020-02-24 12:34:53 UTC
+++ This bug was initially created as a clone of Bug #1802300 +++

Description of problem:
Pre-canned queries need to be updated in monitoring dashboard & metrics tabs as per design doc https://docs.google.com/document/d/1xkYXr_RijaXJwN6AdOcQNzJyyydK9RAVBeUvAqtex50/edit?usp=sharing

Version-Release number of selected component (if applicable): 4.4


How reproducible:


Steps to Reproduce:
1. Navigate to Monitoring page under Developer perspective
2. Select Dashboard tab & Metrics tab separately 
3. Validate metrics list displayed on each tab

Actual results:
Network Transfer in/out, Local Storage & Attached Storage are missing under Dashboard tab. Inappropriate friendly names listed for pre-canned queries in metrics tab

Expected results:
In Dashboard tab, Network Transfer in/out, Local Storage & Attached Storage metrics need to displayed in addition to existing list of metrics. Friendly names listed for pre-canned queries in metrics tab need to be corrected with valid names.

Additional info:

Comment 3 spathak@redhat.com 2020-03-03 16:34:23 UTC
Created attachment 1667236 [details]
Dev-Monitoring: Pre-canned queries updated in monitoring dashboard & metrics tabs-1

Comment 4 spathak@redhat.com 2020-03-03 16:35:36 UTC
Created attachment 1667237 [details]
Dev-Monitoring: Pre-canned queries updated in monitoring dashboard & metrics tabs-2

Comment 5 spathak@redhat.com 2020-03-03 16:36:23 UTC
Created attachment 1667238 [details]
Dev-Monitoring: Pre-canned queries updated in monitoring dashboard & metrics tabs-3

Comment 6 spathak@redhat.com 2020-03-03 16:37:22 UTC
Created attachment 1667239 [details]
Dev-Monitoring: Pre-canned queries updated in monitoring dashboard & metrics tabs-4

Comment 7 spathak@redhat.com 2020-03-03 16:38:49 UTC
Created attachment 1667240 [details]
Dev-Monitoring: Pre-canned queries updated in monitoring dashboard & metrics tabs-5

Comment 8 spathak@redhat.com 2020-03-03 16:40:32 UTC
Verified on build : 4.5.0-0.ci-2020-03-03-053944
Chrome browser: 76.0.3809.132

Comment 10 errata-xmlrpc 2020-08-04 18:02:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5 image release advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.