Bug 1802429 - Order by Age don't work on Serverless -> Services list page
Summary: Order by Age don't work on Serverless -> Services list page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: ralpert
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1806157
TreeView+ depends on / blocked
 
Reported: 2020-02-13 06:14 UTC by Yadan Pei
Modified: 2020-07-13 17:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Services were being listed in alphabetical order, so that oc wasn't the first option. I pulled it out of the sort and appended it to the front so it would be first.
Clone Of:
: 1806157 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:14:44 UTC
Target Upstream Version:


Attachments (Terms of Use)
Serverless Services list page (128.07 KB, image/png)
2020-02-17 09:38 UTC, Yadan Pei
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4355 None closed Bug 1802429: Fix sorting by age in serverless services 2020-06-23 08:28:38 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:15:14 UTC

Description Yadan Pei 2020-02-13 06:14:37 UTC
Description of problem:
In Serverless -> Services list table, Age column ordering don't work

Version-Release number of selected component (if applicable):
serverless-operator.v1.4.0
4.4.0-0.nightly-2020-02-12-191550


How reproducible:
Always

Steps to Reproduce:
1. Enable OpenShift Serverless operator 
2. Create several example service at Serverless -> Services page using default YAML
3. Check resources on Serverless -> Services list page and order by Age


Actual results:
3. Table data didn't change when Age ordering direction is changed

Expected results:
3. Table data should change accordingly when Age ordering direction is changed

Additional info:

Comment 1 bpeterse 2020-02-14 10:58:29 UTC
I was not able to reproduce, but lets confirm specificity:
- Install OpenShift Serverless Operator from OperatorHub
- Create knative-serving namespace (required by operator)
- Create instances of knative-serving (operand)
- View knative serving tab on the Installed Operators -> OpenShift Serverless Operator -> Operator Details page
- Sort by last updated column (age?) 

This sorting function works.

Comment 2 Yadan Pei 2020-02-17 08:49:47 UTC
Hi Ben,

Tried to get a screenshot then it would be much clear, but failed to install OpenShift Serverless Operator today. 

The issue is Order by 'Age' on Serverless -> Services list page not Installed Operators page. Let me know if it's still not clear

Comment 3 Yadan Pei 2020-02-17 09:38:47 UTC
Created attachment 1663476 [details]
Serverless Services list page

I installed OpenShift Serverless Operator successfully and got a screenshot of the page, it's much clear

Comment 6 Yadan Pei 2020-03-06 07:18:04 UTC
1. Enable OpenShift Serverless operator, and create Knative Serving instance
cat > serving.yaml << EOF
apiVersion: v1
kind: Namespace
metadata:
 name: knative-serving
---
apiVersion: operator.knative.dev/v1alpha1
kind: KnativeServing
metadata:
 name: knative-serving
 namespace: knative-serving
EOF
$ oc apply -f serving.yaml

2. Create several example service at Serverless -> Services page using default YAML
3. Check resources on Serverless -> Services list page and order by Age

When we change ordering direction, the table row changes too


Verified on 4.5.0-0.ci-2020-03-04-223611

Comment 8 errata-xmlrpc 2020-07-13 17:14:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.