Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1806157 - Order by Age don't work on Serverless -> Services list page
Summary: Order by Age don't work on Serverless -> Services list page
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: ralpert
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1802429
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-22 13:32 UTC by Samuel Padgett
Modified: 2020-04-29 14:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1802429
Environment:
Last Closed: 2020-04-29 14:23:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4397 0 None closed [release-4.4] Bug 1806157: Fix sorting by age in serverless services 2020-04-29 14:22:45 UTC

Description Samuel Padgett 2020-02-22 13:32:02 UTC
+++ This bug was initially created as a clone of Bug #1802429 +++

Description of problem:
In Serverless -> Services list table, Age column ordering don't work

Version-Release number of selected component (if applicable):
serverless-operator.v1.4.0
4.4.0-0.nightly-2020-02-12-191550


How reproducible:
Always

Steps to Reproduce:
1. Enable OpenShift Serverless operator 
2. Create several example service at Serverless -> Services page using default YAML
3. Check resources on Serverless -> Services list page and order by Age


Actual results:
3. Table data didn't change when Age ordering direction is changed

Expected results:
3. Table data should change accordingly when Age ordering direction is changed

Additional info:

--- Additional comment from  on 2020-02-14 10:58:29 UTC ---

I was not able to reproduce, but lets confirm specificity:
- Install OpenShift Serverless Operator from OperatorHub
- Create knative-serving namespace (required by operator)
- Create instances of knative-serving (operand)
- View knative serving tab on the Installed Operators -> OpenShift Serverless Operator -> Operator Details page
- Sort by last updated column (age?) 

This sorting function works.

--- Additional comment from Yadan Pei on 2020-02-17 08:49:47 UTC ---

Hi Ben,

Tried to get a screenshot then it would be much clear, but failed to install OpenShift Serverless Operator today. 

The issue is Order by 'Age' on Serverless -> Services list page not Installed Operators page. Let me know if it's still not clear

--- Additional comment from Yadan Pei on 2020-02-17 09:38:47 UTC ---

I installed OpenShift Serverless Operator successfully and got a screenshot of the page, it's much clear

Comment 3 Yadan Pei 2020-02-24 07:17:38 UTC
1. Install OpenShift Serverless Operator
2. Create knative serving instance

# cat serving.yaml 
apiVersion: v1
kind: Namespace
metadata:
 name: knative-serving
---
apiVersion: operator.knative.dev/v1alpha1
kind: KnativeServing
metadata:
 name: knative-serving
 namespace: knative-serving

# oc apply -f serving.yaml 
namespace/knative-serving created
knativeserving.operator.knative.dev/knative-serving created

3. Create two services at Serverless -> Services page 
4. Order by Age in Serverless -> Services list page, now the order works 

Verified on     4.4.0-0.nightly-2020-02-23-191320


Note You need to log in before you can comment on or make changes to this bug.