Bug 1802570 - Error when Image-stream tag from internal registry option is selected
Summary: Error when Image-stream tag from internal registry option is selected
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: divgupta
QA Contact: Jaivardhan Kumar
URL:
Whiteboard:
Depends On:
Blocks: 1808257
TreeView+ depends on / blocked
 
Reported: 2020-02-13 12:22 UTC by divgupta
Modified: 2020-07-13 17:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1808257 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:15:07 UTC
Target Upstream Version:


Attachments (Terms of Use)
Steps to reproduce error in second scenario (9.40 MB, image/gif)
2020-02-13 12:22 UTC, divgupta
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4293 0 None closed Bug 1802570: Error when Image-stream tag is selected from internal registry 2020-06-23 08:29:16 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-07-13 17:15:44 UTC

Description divgupta 2020-02-13 12:22:04 UTC
Created attachment 1662948 [details]
Steps to reproduce error in second scenario

Description of problem:

There are 2 scenarios in which this error occurs:

1) When Image stream tag is selected from the internal registry in deploy image add flow, UI crashes `Invariant Violation`.

Steps to reproduce:

1. Navigate to Deploy Image add option
2. First select Image name from external registry and search for this image 
   'yapei/wordpress`
3. Then select Image stream tag from internal registry option.
4. UI crashes with `Invariant Violation` error.

2) In internal registry deploy image edit flow, initially if imagestream is changed after changing the namespace, `SearchStatus` component crashes UI giving `Invariant Violation` error.

Steps to reproduce:
Please see the attached gif.

Comment 3 Jaivardhan Kumar 2020-03-03 14:38:43 UTC
Verified on 

OpenShift Version
4.5.0-0.ci-2020-03-03-053944
Kubernetes Version
v1.17.1
Channel
stable-4.4
Cluster ID
38516298-4998-46a3-8674-2dbdfe6f7192
API Server
https://api.ci-ln-31jj94b-d5d6b.origin-ci-int-aws.dev.rhcloud.com:6443

Comment 5 errata-xmlrpc 2020-07-13 17:15:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.