Bug 1808257 - Error when Image-stream tag from internal registry option is selected
Summary: Error when Image-stream tag from internal registry option is selected
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: divgupta
QA Contact: Jaivardhan Kumar
URL:
Whiteboard:
Depends On: 1802570
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-28 06:28 UTC by divgupta
Modified: 2020-05-04 11:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1802570
Environment:
Last Closed: 2020-05-04 11:43:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4550 0 None closed [release-4.4] Bug 1808257: Error when Image-stream tag is selected from internal registry 2020-05-04 04:38:32 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:43:33 UTC

Description divgupta 2020-02-28 06:28:00 UTC
+++ This bug was initially created as a clone of Bug #1802570 +++

Description of problem:

There are 2 scenarios in which this error occurs:

1) When Image stream tag is selected from the internal registry in deploy image add flow, UI crashes `Invariant Violation`.

Steps to reproduce:

1. Navigate to Deploy Image add option
2. First select Image name from external registry and search for this image 
   'yapei/wordpress`
3. Then select Image stream tag from internal registry option.
4. UI crashes with `Invariant Violation` error.

2) In internal registry deploy image edit flow, initially if imagestream is changed after changing the namespace, `SearchStatus` component crashes UI giving `Invariant Violation` error.

Steps to reproduce:
Please see the attached gif.

Comment 3 Jaivardhan Kumar 2020-03-03 15:16:32 UTC
Verified on 

OpenShift Version
4.4.0-0.ci-2020-03-03-033811
Kubernetes Version
v1.17.1
Channel
stable-4.4
Cluster ID
37161db2-0014-4306-b745-440768152cb5
API Server
https://api.sp79.devcluster.openshift.com:6443

Comment 5 errata-xmlrpc 2020-05-04 11:43:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.