Bug 1802661
| Summary: | [ovirt_disk] Cannot execute the module with basic parameters when uploading QCOW image | ||
|---|---|---|---|
| Product: | Red Hat Enterprise Virtualization Manager | Reporter: | Jan Zmeskal <jzmeskal> |
| Component: | ansible | Assignee: | shani <sleviim> |
| Status: | CLOSED DUPLICATE | QA Contact: | Lucie Leistnerova <lleistne> |
| Severity: | medium | Docs Contact: | |
| Priority: | unspecified | ||
| Version: | 4.4.0 | CC: | isaranov, mperina, sleviim, tnisan |
| Target Milestone: | ovirt-4.4.0 | ||
| Target Release: | --- | ||
| Hardware: | Unspecified | ||
| OS: | Unspecified | ||
| Whiteboard: | |||
| Fixed In Version: | Doc Type: | If docs needed, set a value | |
| Doc Text: | Story Points: | --- | |
| Clone Of: | Environment: | ||
| Last Closed: | 2020-03-23 09:47:49 UTC | Type: | Bug |
| Regression: | --- | Mount Type: | --- |
| Documentation: | --- | CRM: | |
| Verified Versions: | Category: | --- | |
| oVirt Team: | Storage | RHEL 7.3 requirements from Atomic Host: | |
| Cloudforms Team: | --- | Target Upstream Version: | |
| Embargoed: | |||
Additional info: I tried running the same playbook with the same ansible version against RHV 4.3.8.2 and had no problem The failure we see in this oVirt module is most probably caused by a bug in API describe here: https://bugzilla.redhat.com/show_bug.cgi?id=1803473 So now the question is, do we have a way how to have more specific error message in such case? *** This bug has been marked as a duplicate of bug 1798139 *** |
Description of problem: This was brought to my attention when an automated test verifying sanity of oVirt.image-template role began to fail. I dug a little deeper and found out that it fails during task "Deploy the qcow image to oVirt engine" that uses ovirt_vm module. This module, even when called separately, fails with this message: fatal: [localhost]: FAILED! => {"changed": false, "msg": "Fault reason is \"Operation Failed\". Fault detail is \"[General command validation failure.]\". HTTP response code is 500." Version-Release number of selected component (if applicable): rhvm-4.4.0-0.20.master.el7.noarch ansible-2.9.4-1.el7ae.noarch How reproducible: 100 % Steps to Reproduce: 1. Have a QCOW2 image ready at your local machine 2. Prepare a playbook similar to this one: - hosts: localhost gather_facts: false tasks: - ovirt_auth: url: https://<my_engine>/ovirt-engine/api username: admin@internal password: <my_password> insecure: yes - ovirt_disk: auth: "{{ ovirt_auth }}" name: "jzmeskal" size: "4GiB" upload_image_path: "/tmp/Fedora-Cloud-Base-Rawhide-20200211.n.0.x86_64.qcow2" storage_domain: "jzmeskal_engine_1" 3. Run ansible-playbook /path/to/your/playbook.yaml Actual results: http://pastebin.test.redhat.com/835929 Expected results: I don't see any reason why this shouldn't upload the image successfully. Additional info: I verified I was able to upload the image via webadmin.