Bug 1803132 - VM Wizard always uses VirtIO for the VM rootdisk regardless what is defined in common-template
Summary: VM Wizard always uses VirtIO for the VM rootdisk regardless what is defined i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.0
Assignee: Ido Rosenzwig
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On:
Blocks: 1810449
TreeView+ depends on / blocked
 
Reported: 2020-02-14 14:41 UTC by Radim Hrazdil
Modified: 2020-07-13 17:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: VM Wizard always uses VirtIO for the VM rootdisk regardless what is defined in common-template Consequence: VM disk may use an invalid disk type Fix: Check the valid bus type using the VM's template Result: VM rootdisk is created with a valid bus type
Clone Of:
: 1810449 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:15:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4395 None closed Bug 1803132: validate default storage interface on VM wizard 2020-05-20 08:49:25 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:15:58 UTC

Description Radim Hrazdil 2020-02-14 14:41:51 UTC
Description of problem:

VM Wizard seems to always use VirtIO interface for VM rootdisk instead of using interface specified in the common template

Version-Release number of selected component (if applicable):
4.4

How reproducible:
100%

Steps to Reproduce:
0. Open VM Wizard
1. Select Windows OS
2. proceed to Storage section

Actual results:
rootdisk has default interface VirtIO

Expected results:
The default interface should be selected based on common-template used, which in case of Windows VM should be sata:

disks:
  - disk:
    bus: sata
    name: rootdisk

Additional info:

Comment 3 Guohua Ouyang 2020-03-31 06:50:05 UTC
verified on 4.5.0-0.nightly-2020-03-29-224016.

Comment 5 errata-xmlrpc 2020-07-13 17:15:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.