Bug 1810449 - VM Wizard always uses VirtIO for the VM rootdisk regardless what is defined in common-template
Summary: VM Wizard always uses VirtIO for the VM rootdisk regardless what is defined i...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Kubevirt Plugin
Version: 4.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.4.0
Assignee: Ido Rosenzwig
QA Contact: Nelly Credi
URL:
Whiteboard:
Depends On: 1803132
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-03-05 09:52 UTC by Ido Rosenzwig
Modified: 2020-05-13 22:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1803132
Environment:
Last Closed: 2020-05-13 22:00:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4650 0 None closed [release-4.4] Bug 1810449: validate default storage interface on VM w… 2020-03-25 04:10:31 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 22:00:47 UTC

Description Ido Rosenzwig 2020-03-05 09:52:06 UTC
+++ This bug was initially created as a clone of Bug #1803132 +++

Description of problem:

VM Wizard seems to always use VirtIO interface for VM rootdisk instead of using interface specified in the common template

Version-Release number of selected component (if applicable):
4.4

How reproducible:
100%

Steps to Reproduce:
0. Open VM Wizard
1. Select Windows OS
2. proceed to Storage section

Actual results:
rootdisk has default interface VirtIO

Expected results:
The default interface should be selected based on common-template used, which in case of Windows VM should be sata:

disks:
  - disk:
    bus: sata
    name: rootdisk

Additional info:

--- Additional comment from errata-xmlrpc on 2020-03-04 20:10:55 UTC ---

This bug has been added to advisory RHBA-2020:51809 by OpenShift Release Team Bot (ocp-build/buildvm.openshift.eng.bos.redhat.com@REDHAT.COM)

--- Additional comment from errata-xmlrpc on 2020-03-04 20:10:56 UTC ---

Bug report changed to ON_QA status by Errata System.
A QE request has been submitted for advisory RHBA-2020:51809-01
https://errata.devel.redhat.com/advisory/51809

Comment 3 Guohua Ouyang 2020-03-13 03:26:18 UTC
Not fixed on 4.4.0-0.nightly-2020-03-06-170328, will try a new version.

Comment 4 Guohua Ouyang 2020-03-25 08:19:10 UTC
It's still not fixed on 4.4.0-rc.4.

Not sure whether I verify it correctly, my steps are:

$ oc get template -n openshift windows-server-large-v0.7.0 -o yaml

the spec.spec.domain.devices is:

          devices:
            disks:
            - disk:
                bus: sata
              name: rootdisk

Open VM Wizard -> Select Windows OS, Flavor "large" and workprofile "server" ->proceed to Storage section, it's not "sata" but "VirtIO".

Comment 5 Guohua Ouyang 2020-03-25 09:47:54 UTC
Talked with Ido, it needs to modify validations and then to veirfy the bug.

validations: |
      [
        {
          "name": "minimal-required-memory",
          "path": "jsonpath::.spec.domain.resources.requests.memory",
          "rule": "integer",
          "message": "This VM requires more memory.",
          "min": 536870912
        }, {
          "name": "windows-virtio-bus",
          "path": "jsonpath::.spec.domain.devices.disks[*].disk.bus",
          "rule": "enum",
          "message": "virto disk bus type has better performance, install virtio drivers in VM and change bus type",
          "values": ["virtio"],
          "justWarning": true
        }, {
          "name": "windows-disk-bus",
          "path": "jsonpath::.spec.domain.devices.disks[*].disk.bus",
          "rule": "enum",
          "message": "disk bus has to be either virtio or sata",
          "values": ["scsi", "sata"]
        }
      ]

with above validations, it's showing scsi on storage page.

Comment 7 errata-xmlrpc 2020-05-13 22:00:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.