This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 180315 - /usr/bin/ld: BFD 2.16.1 assertion fail elf64-ppc.c:7973
/usr/bin/ld: BFD 2.16.1 assertion fail elf64-ppc.c:7973
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: binutils (Show other bugs)
3.0
ppc64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-07 02:15 EST by Bin Li
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 13:16:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bin Li 2006-02-07 02:15:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Description of problem:
When we use the default /usr/bin/ld (GNU ld version 2.14.90.0.4 20030523) to link our DEBUG version of SYBASE database server on ibmplinux, it gives error:
/usr/bin/ld: BFD 2.14.90.0.4 20030523 assertion fail ../../bfd/elf64-ppc.c:6226
/usr/bin/ld: BFD 2.14.90.0.4 20030523 assertion fail ../../bfd/elf64-ppc.c:6226

After we downloaded, compiled and installed GNU binutils 2.16.1 from http://ftp.gnu.org/gnu/binutils/, then use the same link option to relink our DEBUG version of database server, it gives error:
/usr/bin/ld: BFD 2.16.1 assertion fail elf64-ppc.c:7973
/usr/bin/ld: BFD 2.16.1 assertion fail elf64-ppc.c:7973

But if we downloaded, compiled and installed GNU binutils CVS version from ftp://sourceware.org/pub/binutils/snapshots, for example, binutils-060126.tar.bz2, then relink our DEBUG version of database server, it can be linked successfully and can run with out problem.

Though we can build out the DEBUG version of database server with binutils CVS version now, we would rather release our database product built with officially released binutils than CVS version.

Will RedHat have a plan to release new version or patched version of binutils recently? We are expecting it to release our database product on ibm pseries linux on schedule.

Version-Release number of selected component (if applicable):
GNU ld version 2.16.1

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  

Additional info:
Comment 1 Bin Li 2006-02-08 01:21:20 EST
This problem is on RH3.0 PowerPC platform, and please provide an officially
released newer version of binutils to replace the latest released 2.16.1 binutils.
Comment 2 Jakub Jelinek 2006-02-08 08:21:19 EST
Upgrading RHEL3 binutils is not an option, such kind of disruptive change
is not suitable for RHEL updates.  If you want 2.16.1+ binutils, you need
to build it yourself, or wait for RHEL5 which will have binutils based on
at least 2.16.91.
If you provide a self-contained testcase, we could look to see what's
going on and why the stub branch overflows (that's the assert you mentioned) and
if consider fixing it.  In current CVS binutils that assert is replaced by
a linker error, so if you aren't getting that error, it means some relaxation
or different section layout led to this overflow not being triggered.
But without a testcase there is nothing we can do with it.
Comment 3 Bin Li 2006-02-26 20:57:10 EST
- To get the repro that leads to binutils is not straight forward and very time
consuming. At this point, Sybase decide to go ahead with using the CVS version
of binutils to get around the diagserver ld ‘assertion failure’.
- In the meantime, we will continue to work on getting the repro for the linking
error however with lower priority.
- Sybase would like to understand if RH will continue support Sybase in case
there is any customer reported problems possibly caused by RH software when the
CVS version of binutils is used. What kind of support would Sybase get?
 
Comment 4 Jakub Jelinek 2006-03-15 13:16:34 EST
I'd say if it is a problem clearly not related to the use of different binutils,
then certainly normal support, otherwise I guess Red Hat and Sybase would need
to cooperate in analysis until it is clear if the problem is on the Red Hat side
or in the binutils used.

Anyway, please reopen this bug when (if) you have a self-contained reproducer.
Thanks.

Note You need to log in before you can comment on or make changes to this bug.