Bug 180332 - scponly denies access when winscp compatibility is disabled
scponly denies access when winscp compatibility is disabled
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: scponly (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
: 180333 (view as bug list)
Depends On:
Blocks: 171491
  Show dependency treegraph
 
Reported: 2006-02-07 07:48 EST by Yannick Majoros
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-17 16:24:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yannick Majoros 2006-02-07 07:48:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)

Description of problem:
My users complained that scp didn't work anymore, from a command line on another linux box to the server on which they have scponly as shell.

I downloaded the lates sources of scponly (4.6), and compiled it. Same problem.

I then recompiled scponly with winscp compatibility option, and the problem was solved.

I think winscp compatibility was enabled by default in prior versions.

Version-Release number of selected component (if applicable):
scponly-4.3-1

How reproducible:
Always

Steps to Reproduce:
1.Create a 'test01' user with /usr/bin/scponly as shell
2.From another box, try scp x test01@target.machine:/tmp
  

Actual Results:  ssh or scp to target server with user which has scponly as shell gives "Connection to target.machine closed."

Expected Results:  should work without having to recompile

Additional info:

When debug level is set to 2:

---8<--8<---
scponly[22776]: 1 arguments in total.
scponly[22776]:         arg 0 is -scponly
scponly[22776]: opened log at LOG_AUTHPRIV, opts 0x00000029
scponly[22776]: incorrect number of args
Connection to target.machine closed.
---8<--8<---
Comment 1 Nalin Dahyabhai 2006-02-07 09:55:24 EST
*** Bug 180333 has been marked as a duplicate of this bug. ***
Comment 2 Warren Togami 2006-02-17 16:24:11 EST
It looks like scp is fully disabled by default despite configure and
documentation saying otherwise in 4.3+.  I have upgraded our FE package to 4.6
and enabled scp with the ./configure flag.  I don't think enabling the winscp
feature is necessary because the newer version of winscp is supposed to work
without it.  It should be pushed to the mirrors later today.

Note You need to log in before you can comment on or make changes to this bug.