Bug 180333 - scponly denies access when winscp compatibility is disabled
Summary: scponly denies access when winscp compatibility is disabled
Status: CLOSED DUPLICATE of bug 180332
Alias: None
Product: Fedora
Classification: Fedora
Component: scponly   
(Show other bugs)
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-07 12:49 UTC by Yannick Majoros
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-07 14:55:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Yannick Majoros 2006-02-07 12:49:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)

Description of problem:
My users complained that scp didn't work anymore, from a command line on another linux box to the server on which they have scponly as shell.

I downloaded the lates sources of scponly (4.6), and compiled it. Same problem.

I then recompiled scponly with winscp compatibility option, and the problem was solved.

I think winscp compatibility was enabled by default in prior versions.

Version-Release number of selected component (if applicable):
scponly-4.3-1

How reproducible:
Always

Steps to Reproduce:
1.Create a 'test01' user with /usr/bin/scponly as shell
2.From another box, try scp x test01@target.machine:/tmp
  

Actual Results:  ssh or scp to target server with user which has scponly as shell gives "Connection to target.machine closed."

Expected Results:  should work without having to recompile

Additional info:

When debug level is set to 2:

---8<--8<---
scponly[22776]: 1 arguments in total.
scponly[22776]:         arg 0 is -scponly
scponly[22776]: opened log at LOG_AUTHPRIV, opts 0x00000029
scponly[22776]: incorrect number of args
Connection to target.machine closed.
---8<--8<---

Comment 1 Nalin Dahyabhai 2006-02-07 14:55:11 UTC

*** This bug has been marked as a duplicate of 180332 ***


Note You need to log in before you can comment on or make changes to this bug.