Bug 1803614 - Alertmanager receiver creation page should mark Routing Labels field by red-star mark
Summary: Alertmanager receiver creation page should mark Routing Labels field by red-s...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.5.0
Assignee: David Taylor
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks: 1807657
TreeView+ depends on / blocked
 
Reported: 2020-02-17 03:42 UTC by XiaochuanWang
Modified: 2020-07-13 17:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: When creating a new Alert Receiver, routing labels are required so a red asterisk was added to the form's Routing Labels section. Reason: Prior to this, there was no visual indication that labels are required. Result: Routing Labels section now has a red asterisk.
Clone Of:
: 1807657 (view as bug list)
Environment:
Last Closed: 2020-07-13 17:15:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4518 None closed Bug 1803614: Alertmanager receiver creation page should mark Routing Labels field by red-star mark 2020-07-07 01:58:20 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-07-13 17:15:58 UTC

Description XiaochuanWang 2020-02-17 03:42:29 UTC
Description of problem:
Cluster admin user goes to Alertmanager Receiver creation page and fill in all requires fields with red-star marks, leave Routing Labels empty which has no mark. Hit Create button but it prompt message that needs values. 

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-02-16-205302

How reproducible:
Always

Steps to Reproduce:
1. Cluster admin user goes to Alertmanager Receiver creation page
2. Fill in all requires fields with red-star marks, leave Routing Labels empty which has no mark.
3. Hit Create button

Actual results:
3. It prompt message that needs values. 

Expected results:
3. The Routing Labels should have the Required mark and Create button should be disabled when it's empty

Additional info:

Comment 1 David Taylor 2020-02-17 16:19:19 UTC
We will have to determine where the required 'red-star-asterisk' should go.  The Routing Label component is a multi-lined editor.

Comment 4 XiaochuanWang 2020-03-06 06:40:46 UTC
Routing Labels is marked as required by red-star mark.
Verified on 4.5.0-0.ci-2020-03-04-223611

Comment 6 errata-xmlrpc 2020-07-13 17:15:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.