Bug 1807657 - Alertmanager receiver creation page should mark Routing Labels field by red-star mark
Summary: Alertmanager receiver creation page should mark Routing Labels field by red-s...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 4.4.0
Assignee: David Taylor
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On: 1803614
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-26 20:57 UTC by David Taylor
Modified: 2020-05-13 22:00 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: Admin -> Cluster Settings -> Global Config -> Alertmanager -> Create Receiver. Add red-start 'required' icon to Routing Labels field. Reason: Routing Label is required but doesn't have the 'required' icon Result: Routing Labels field now has the 'red-star' required icon.
Clone Of: 1803614
Environment:
Last Closed: 2020-05-13 22:00:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4633 0 None closed [release-4.4] Bug 1807657: Alertmanager receiver creation page should mark Routing Labels field by red-star mark 2020-04-20 16:07:51 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 22:00:13 UTC

Description David Taylor 2020-02-26 20:57:46 UTC
+++ This bug was initially created as a clone of Bug #1803614 +++

Description of problem:
Cluster admin user goes to Alertmanager Receiver creation page and fill in all requires fields with red-star marks, leave Routing Labels empty which has no mark. Hit Create button but it prompt message that needs values. 

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-02-16-205302

How reproducible:
Always

Steps to Reproduce:
1. Cluster admin user goes to Alertmanager Receiver creation page
2. Fill in all requires fields with red-star marks, leave Routing Labels empty which has no mark.
3. Hit Create button

Actual results:
3. It prompt message that needs values. 

Expected results:
3. The Routing Labels should have the Required mark and Create button should be disabled when it's empty

Additional info:

--- Additional comment from David Taylor on 2020-02-17 16:19:19 UTC ---

We will have to determine where the required 'red-star-asterisk' should go.  The Routing Label component is a multi-lined editor.

Comment 3 XiaochuanWang 2020-03-09 06:49:04 UTC
Routing Labels is marked as required by red-star mark.
Verified on 4.4.0-0.nightly-2020-03-08-213224

Comment 5 errata-xmlrpc 2020-05-13 22:00:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.