Bug 1803762 - [MHC] Failed to drain node for machine
Summary: [MHC] Failed to drain node for machine
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.3.z
Assignee: Alberto
QA Contact: Jianwei Hou
URL:
Whiteboard: aws
: 1805874 1831651 1841328 (view as bug list)
Depends On: 1733474
Blocks: 1831651
TreeView+ depends on / blocked
 
Reported: 2020-02-17 11:42 UTC by Alexander Demicev
Modified: 2020-06-27 03:17 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1733474
: 1831651 (view as bug list)
Environment:
Last Closed: 2020-05-18 21:12:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-api-provider-azure pull 110 None closed [release-4.3] Bug 1803762: Revendor MAO with new node draining feature check existence before node deletion 2020-08-31 14:54:35 UTC

Comment 1 Alberto 2020-02-24 08:52:00 UTC
This is fixed as part of https://github.com/openshift/cluster-api-provider-aws/pull/298

Comment 2 Alberto 2020-02-24 08:54:52 UTC
*** Bug 1805874 has been marked as a duplicate of this bug. ***

Comment 3 Alexander Demicev 2020-05-05 12:40:45 UTC
*** Bug 1831651 has been marked as a duplicate of this bug. ***

Comment 4 Michael Gugino 2020-05-18 21:12:27 UTC
Closing.  A workaround exists, this fix has shipped in 4.4, and does not block upgrades.

Comment 5 Scott Dodson 2020-05-19 15:04:21 UTC
This bug depends on a 4.4 bug, the proper state if we're not fixing this in 4.3.z is WONTFIX.

Comment 6 W. Trevor King 2020-06-27 03:17:58 UTC
*** Bug 1841328 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.