Bug 1803793 - Can't delete a non-existent baremetal host from the GUI
Summary: Can't delete a non-existent baremetal host from the GUI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Metal3 Plugin
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.4.z
Assignee: Jiri Tomasek
QA Contact: Udi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-17 13:33 UTC by Udi
Modified: 2020-06-29 15:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1807891 (view as bug list)
Environment:
Last Closed: 2020-06-29 15:33:54 UTC
Target Upstream Version:


Attachments (Terms of Use)
normal-kebab-list (95.90 KB, image/png)
2020-05-21 07:29 UTC, Yanping Zhang
no flags Details
notreadyhost-kebab-list (81.72 KB, image/png)
2020-05-21 07:31 UTC, Yanping Zhang
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 4609 None closed Bug 1803793: Allow deleting BM hosts in unknown status 2020-07-10 08:37:42 UTC
Red Hat Product Errata RHBA-2020:2713 None None None 2020-06-29 15:34:17 UTC

Description Udi 2020-02-17 13:33:19 UTC
Description of problem:
I created a new host under "Bare Metal Hosts", with bogus ipmi details of something which doesn't exist. The host was created and was stuck in "powering on" state. I wanted to delete it - but the "Delete" command was not available in the kebab menu of the host.

In addition, the host was created in the "default" namespace, which means that it won't get touched by the operator. We need the ability to delete such hosts.


Version-Release number of selected component (if applicable):
4.3.1


How reproducible:
100%


Steps to Reproduce:
1. Navigate to the bare metal hosts page and make sure you're viewing "all projects"
2. Create a baremetal host with bogus IPMI details, for example I used 'ipmi://[2001:0db8:85a3:0000:0000:8a2e:0370:7334]:6032'
3. Try deleting this host from the GUI


Actual results:
No option to delete

Comment 5 Yanping Zhang 2020-05-21 07:28:41 UTC
Checked on 4.4 cluster with payload: 4.4.0-0.nightly-2020-05-18-164758
On "Bare Metal Hosts" page, no matter the host status, could not find "delete" item in kebab list.
Where can we see "delete" item?

Comment 6 Yanping Zhang 2020-05-21 07:29:36 UTC
Created attachment 1690540 [details]
normal-kebab-list

Comment 7 Yanping Zhang 2020-05-21 07:31:03 UTC
Created attachment 1690541 [details]
notreadyhost-kebab-list

Comment 9 Jiri Tomasek 2020-05-28 10:19:04 UTC
Host which runs workloads or is in progress state (e.g. registering) can not be deleted. To delete the host, it needs to be deprovisioned first.

Note that this bug was originally open for allowing removing host which was in 'unknown' state, which is now fixed.

Comment 10 Udi 2020-06-17 13:04:47 UTC
Verified: 4.4.0-0.nightly-2020-06-15-203705

Comment 13 errata-xmlrpc 2020-06-29 15:33:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2713


Note You need to log in before you can comment on or make changes to this bug.