Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1807891 - Can't delete a non-existent baremetal host from the GUI
Summary: Can't delete a non-existent baremetal host from the GUI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Console Metal3 Plugin
Version: 4.3.z
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.6.0
Assignee: Jiri Tomasek
QA Contact: Yanping Zhang
URL:
Whiteboard:
Depends On: 1840090
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-27 12:35 UTC by Jiri Tomasek
Modified: 2020-10-27 15:56 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1803793
Environment:
Last Closed: 2020-10-27 15:55:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
deletebmhost (132.84 KB, image/png)
2020-05-25 09:14 UTC, Yanping Zhang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4529 0 None closed Bug 1807891: Allow deleting BM hosts in unknown status 2020-09-10 01:44:30 UTC
Red Hat Product Errata RHBA-2020:4196 0 None None None 2020-10-27 15:56:10 UTC

Description Jiri Tomasek 2020-02-27 12:35:07 UTC
+++ This bug was initially created as a clone of Bug #1803793 +++

Description of problem:
I created a new host under "Bare Metal Hosts", with bogus ipmi details of something which doesn't exist. The host was created and was stuck in "powering on" state. I wanted to delete it - but the "Delete" command was not available in the kebab menu of the host.

In addition, the host was created in the "default" namespace, which means that it won't get touched by the operator. We need the ability to delete such hosts.


Version-Release number of selected component (if applicable):
4.3.1


How reproducible:
100%


Steps to Reproduce:
1. Navigate to the bare metal hosts page and make sure you're viewing "all projects"
2. Create a baremetal host with bogus IPMI details, for example I used 'ipmi://[2001:0db8:85a3:0000:0000:8a2e:0370:7334]:6032'
3. Try deleting this host from the GUI


Actual results:
No option to delete

Comment 3 Yanping Zhang 2020-05-25 09:13:48 UTC
Checked on 4.5 BM cluster with payload 4.5.0-0.nightly-2020-05-22-062554.
Check Bare Metal Hosts on console, there are hosts in "Unknown" status. Click "Delete Bare Metal Host" in the action list, could submit the deletion. But wait for a moment, the Bare Metal Host is not exactly deleted, it's still listed in the table. Pls refer to the screenshot.

Comment 4 Yanping Zhang 2020-05-25 09:14:25 UTC
Created attachment 1691770 [details]
deletebmhost

Comment 5 Jiri Tomasek 2020-05-28 11:05:59 UTC
I suspect this to be related to https://bugzilla.redhat.com/show_bug.cgi?id=1840090
Also it seems there is a bug in BMO which causes the hosts never to finish the deletion.

Comment 6 Tomas Jelinek 2020-05-28 12:18:16 UTC
This bug depends on 1840090 which is not even posted. The code freeze is tomorrow. This bug does not prevent the user from accomplishing a task, it is only annoying since a host which does not do anything is there and you can not delete it. Moving to 4.6. If you have a strong objection, please feel free to propose 4.5.z

Comment 7 Tomas Jelinek 2020-05-29 08:30:14 UTC
Unfortunately there was no capacity this sprint to do this. Moving to upcoming.

Comment 9 Jiri Tomasek 2020-07-10 08:42:59 UTC
The bug is now fixed as per comment in dependent bug https://bugzilla.redhat.com/show_bug.cgi?id=1840090#c6

Comment 13 Yadan Pei 2020-08-07 09:02:26 UTC
no IPI on BM cluster available now

Comment 14 Yanping Zhang 2020-09-10 01:51:13 UTC
Checked on ocp 4.6 ipi-bm with payload 4.6.0-0.nightly-2020-09-09-003430 
Create a BM host on cluster, then click "Delete Bare Metal Host" from action list, confirm deletion. The BM host is deleted successfully.
The bug is fixed.

Comment 16 errata-xmlrpc 2020-10-27 15:55:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6 GA Images), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:4196


Note You need to log in before you can comment on or make changes to this bug.