Bug 1803865 - Topology In-Context Connector Shouldn't Prompt on Existing Connections
Summary: Topology In-Context Connector Shouldn't Prompt on Existing Connections
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.5.0
Assignee: Jeff Phillips
QA Contact: Ruchir Garg
URL:
Whiteboard:
Depends On:
Blocks: 1806976
TreeView+ depends on / blocked
 
Reported: 2020-02-17 15:49 UTC by Jeff Phillips
Modified: 2020-08-04 18:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1806976 (view as bug list)
Environment:
Last Closed: 2020-08-04 18:00:44 UTC
Target Upstream Version:


Attachments (Terms of Use)
Verification of bug on 4.5 release (8.43 MB, image/gif)
2020-03-02 16:07 UTC, Abhishek K N
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4342 0 None closed Bug 1803865: Fix to show Add popup only on graph and application groups 2020-07-28 17:00:14 UTC
Red Hat Product Errata RHBA-2020:2409 0 None None None 2020-08-04 18:00:48 UTC

Description Jeff Phillips 2020-02-17 15:49:07 UTC
Description of problem:

In the topology view, creating a new connection should not prompt to add a new item when clicking on existing items.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create two nodes and add a visual connector to them
2. Now try to connect from same source to same destination

Actual results:

You will see the popup menu for creating a new node from topology page

Expected results:

No menu should be shown

Additional info:

In addition, the menu should only be shown on the Graph (blank area) or within an application grouping. It should not show when dropped on a node, HELM grouping, Operator grouping, or knative service (group).

Comment 3 Abhishek K N 2020-03-02 16:06:56 UTC
Verified the bug on 4.5 CI build. When trying to recreate a visual connector which already exists between a source & destination node, popup menu to create a new node is not displayed (PSA).

Verified build: 4.5.0-0.ci-2020-03-01-212531
Verified browsers: Chrome Version 80.0.3987.116 (Official Build) (64-bit), Safari Version 13.0.5 (14608.5.12)

Comment 4 Abhishek K N 2020-03-02 16:07:54 UTC
Created attachment 1667008 [details]
Verification of bug on 4.5 release

Comment 6 errata-xmlrpc 2020-08-04 18:00:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5 image release advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.