Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1806976 - Topology In-Context Connector Shouldn't Prompt on Existing Connections
Summary: Topology In-Context Connector Shouldn't Prompt on Existing Connections
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 4.4.0
Assignee: Jeff Phillips
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On: 1803865
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-25 11:53 UTC by Jeff Phillips
Modified: 2020-05-04 11:42 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of: 1803865
Environment:
Last Closed: 2020-05-04 11:42:22 UTC
Target Upstream Version:


Attachments (Terms of Use)
Verification of bug on 4.4 release (10.69 MB, image/gif)
2020-03-02 16:16 UTC, Abhishek K N
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4453 0 None closed [release-4.4] Bug 1806976: Fix to show Add popup only on graph and application groups 2020-04-28 20:22:02 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-04 11:42:41 UTC

Description Jeff Phillips 2020-02-25 11:53:30 UTC
+++ This bug was initially created as a clone of Bug #1803865 +++

Description of problem:

In the topology view, creating a new connection should not prompt to add a new item when clicking on existing items.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create two nodes and add a visual connector to them
2. Now try to connect from same source to same destination

Actual results:

You will see the popup menu for creating a new node from topology page

Expected results:

No menu should be shown

Additional info:

In addition, the menu should only be shown on the Graph (blank area) or within an application grouping. It should not show when dropped on a node, HELM grouping, Operator grouping, or knative service (group).

Comment 3 Abhishek K N 2020-03-02 16:15:29 UTC
Verified the bug on 4.4 CI build. When trying to recreate a visual connector which already exists between a source & destination node, popup menu to create a new node is not displayed (PSA).

Verified build: 4.4.0-0.ci-2020-03-01-110146
Verified browsers: Chrome Version 80.0.3987.116 (Official Build) (64-bit), Safari Version 13.0.5 (14608.5.12)

Comment 4 Abhishek K N 2020-03-02 16:16:31 UTC
Created attachment 1667009 [details]
Verification of bug on 4.4 release

Comment 6 errata-xmlrpc 2020-05-04 11:42:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.