Bug 1803941 - Helm endpoints do not return valid json response in case of runtime errors
Summary: Helm endpoints do not return valid json response in case of runtime errors
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Dev Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.5.0
Assignee: Predrag Knezevic
QA Contact: Gajanan More
URL:
Whiteboard:
Depends On:
Blocks: 1806153
TreeView+ depends on / blocked
 
Reported: 2020-02-17 18:44 UTC by Predrag Knezevic
Modified: 2020-05-13 21:58 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
: 1806153 (view as bug list)
Environment:
Last Closed: 2020-05-13 21:58:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift console pull 4088 0 None closed Bug 1803941: close helm request on error 2020-05-21 22:04:26 UTC
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:58:23 UTC

Description Predrag Knezevic 2020-02-17 18:44:11 UTC
Description of problem:

If a helm endpoint action ends with the error, the returned response is not a valid json content.


How reproducible:

POST request at /api/helm/manifest/releases with the following payload

{
	"chart_url": "foo"
}


Actual results:

{
  "error": "Failed to install helm chart: failed to download \"foo\" (hint: running `helm repo update` may help)"
}null

Expected results:

{
  "error": "Failed to install helm chart: failed to download \"foo\" (hint: running `helm repo update` may help)"
}

Comment 3 Gajanan More 2020-03-10 08:57:50 UTC
I have validated this bug on 
Build: 4.5.0-0.ci-2020-03-10-023720
Browser: Google Chrome 78.0.3904.108
Marking this bug as verified.

Comment 5 errata-xmlrpc 2020-05-13 21:58:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.