Bug 180397 - RHEL3 U7 x86_64 pci resource conflict on sc430
RHEL3 U7 x86_64 pci resource conflict on sc430
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.7
x86_64 Linux
high Severity medium
: ---
: ---
Assigned To: John Feeney
Brian Brock
NdRvw
:
: 180433 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-07 15:21 EST by Jeff Burke
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-06 16:10:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci -vvv when installing x86_64 (this failed) (10.54 KB, text/plain)
2006-02-07 15:30 EST, Jeff Burke
no flags Details
lscpi -vvv RHEL3 U7 x86 (This works) (10.54 KB, text/plain)
2006-02-07 15:37 EST, Jeff Burke
no flags Details

  None (edit)
Description Jeff Burke 2006-02-07 15:21:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
I am running into an issue with the dell sc430 when trying to install rhel3 x86_64. rhel3 x86 installs fine. but rhel3 x86_64 fails. during the install it can't find the harddrive.

Tried several standard options noacpi, apci=noirq ... All of which failed.

http://www.dell.com/downloads/global/products/pedge/en/sc430_specs.pdf

Message in /var/log/messages
ata_pix version 1.03
PCI: Device 00:1f:2 not available because of resource collisions

I spoke with Jeff G he said "ata_piix can only ask other subsystems for resources. It has no control over (a) what resources are there, and (b) whether it can "own" the resources or not"


Version-Release number of selected component (if applicable):
2.4.21-37.EL

How reproducible:
Always

Steps to Reproduce:
1. Use a dell sc430 to install RHEL3 U7 x86_64.
  

Actual Results:  The installed failed because it could not find a valid harddrive

Expected Results:  The system should have found the harddrive

Additional info:

This works with RHEL3 U7 x86, and Fedora FC4.
 
It is _not_ a regression
Comment 1 Jeff Burke 2006-02-07 15:28:13 EST
I put in the wrong kernel version in the original BZ, I was testing RHEL3 U6 to
make sure it was not a regression. I have tried this with both 2.4.21-40 and
2.4.21-37 U6 and U7 both fail.

As per recommendation from Jeff G I will attach a lspci -vvv 
Comment 2 Jeff Burke 2006-02-07 15:30:04 EST
Created attachment 124333 [details]
lspci -vvv when installing x86_64 (this failed)
Comment 3 Jeff Burke 2006-02-07 15:37:48 EST
Created attachment 124334 [details]
lscpi -vvv RHEL3 U7 x86 (This works)
Comment 4 Ernie Petrides 2006-02-08 18:40:22 EST
*** Bug 180433 has been marked as a duplicate of this bug. ***
Comment 7 Ernie Petrides 2006-06-14 19:49:48 EDT
Reapplying lost comment from jburke@redhat.com on 2006-06-13 10:36 EST:


This is now working. I have tested it with RHEL3-U8 beta tree.
Comment 9 Matt Brodeur 2006-10-19 12:01:37 EDT
It looks like this is actually NOT working in the released U8 tree.  I'm still
seeing the same problem on the system I originally filed bug 180433 on.  Jeff
Burke retried an install on the system mentioned in comment #7, and that's not
working either.
Comment 15 John Feeney 2007-03-06 16:10:04 EST
Since by all indications, this bug is germaine only to the Dell SC430 and, 
according to Dell, RHEL3 U9 won't be supported on the SC430, this bugzilla
is being set to WONTFIX.

Note You need to log in before you can comment on or make changes to this bug.