Bug 180399 - 'yum update' killed by OOM killer
'yum update' killed by OOM killer
Status: CLOSED DUPLICATE of bug 179547
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
5
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-07 15:38 EST by Lonni J Friedman
Modified: 2014-01-21 17:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-07 16:45:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lonni J Friedman 2006-02-07 15:38:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1

Description of problem:
I'm running FC5-test2 (plus regular updates), and I typically run 'yum update' about once/week to pick up the latest changes.  The last time that I was able to do so successfully was on February 1.  Attempting to run yum update today results in yum using up all the RAM (8GB) plus swap (2GB) on the system getting exhausted and the OOM killer kicking in and killing yum.  

I ran "yum clean all" to see if that would help, but that had no impact on the update problem.

I'm using the 2.6.15-1.1884_FC5 kernel in a dual Opteron system.

Version-Release number of selected component (if applicable):
yum-2.5.1-3

How reproducible:
Always

Steps to Reproduce:
1.run "yum update"
2.
3.
  

Actual Results:  OOM killer kicks in and kills hte process after all RAM+swap is exhausted

Expected Results:  yum should have actually updated all packages

Additional info:
Comment 1 Jeremy Katz 2006-02-07 16:45:35 EST

*** This bug has been marked as a duplicate of 179547 ***

Note You need to log in before you can comment on or make changes to this bug.