Bug 179547 - python-sqlite breaks yum (after update to the sqlite-3.3.3-1)
python-sqlite breaks yum (after update to the sqlite-3.3.3-1)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python-sqlite (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Paul Nasrat
:
: 179554 179587 179648 180072 180399 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-02-01 05:57 EST by Harald Hoyer
Modified: 2007-11-30 17:11 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-06 10:58:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for python-sqlite (476 bytes, patch)
2006-02-01 19:25 EST, Pavel Roskin
no flags Details | Diff

  None (edit)
Description Harald Hoyer 2006-02-01 05:57:44 EST
Description of problem:
yum allocated an infinite amount of RAM

Version-Release number of selected component (if applicable):
sqlite-3.3.3-1

How reproducible:
every time

Steps to Reproduce:
1. yum list
  
Actual results:
OOM

Expected results:
a list

Additional info:
downgrading to sqlite-3.3.2-1 fixes the problem
Comment 1 Justin Conover 2006-02-01 07:39:15 EST
Had to remove beagle and f-spot

rpm -e beagle f-spot
rpm -Uvh --oldpackage sqlite-3.2.8-1.i386.rpm
Comment 2 Rahul Sundaram 2006-02-01 07:53:59 EST
*** Bug 179554 has been marked as a duplicate of this bug. ***
Comment 3 Paul Nasrat 2006-02-01 10:25:22 EST
Thanks for the report - replicated here, and seen in the installer too.

Chris did you test yum with updated sqlite?
Comment 4 Christopher Aillon 2006-02-01 10:28:47 EST
Actually, yes.  I yum updated yesterday with the new package I built, so I don't
see the issue.  Since harald said that 3.3.2 worked, I just posted that RPM here
since it never was released:
http://people.redhat.com/caillon/RPMS/rawhide/sqlite-3.3.2-1.i386.rpm
Comment 5 Paul Nasrat 2006-02-01 10:40:22 EST
My reproducer that Chris has confirmed:

yum update sqlite
yum clean all
yum list updates 

Comment 6 Milan Kerslager 2006-02-01 10:55:58 EST
I'm confirming the bug in sqlite too. Downgrading yum did not help. Downgrading
sqlite fixed the problem:

sqlite-3.2.7-2.1.i386.rpm (from FCtest2) yum works
sqlite-3.3.2-1.i386.rpm (from comment #4) yum works
Comment 7 Kostas Georgiou 2006-02-01 11:07:31 EST
Another reproducer: 
python /usr/share/doc/python-sqlite-1.1.6/examples/converters.py
It fails at cu.execute("create table test(p point, n int)")
Comment 8 Paul Nasrat 2006-02-01 11:16:44 EST
Kostas - Thanks for the pointer to the smaller reproducer
Milan - Thanks for the confirmation of working status.
Comment 9 Paul Nasrat 2006-02-01 11:26:16 EST
import sqlite
db = sqlite.connect("test")
cur = db.cursor()
cur.execute("""CREATE TABLE db_info ( dbversion TEXT, checksum TEXT) """)

Comment 10 Paul Nasrat 2006-02-01 11:32:21 EST
This works:

sqlite> .schema db_info
CREATE TABLE db_info (
foo TEXT, bar TEXT);
sqlite>

python-sqlite fails to create tables.
Comment 11 Paul Nasrat 2006-02-01 14:02:59 EST
Root cause by this changeset:

http://www.sqlite.org/cvstrac/tktview?tn=1554

python-sqlite was using 0 for nBytes.  Changing to -1 in python-sqlite fixes.
Comment 12 Paul Nasrat 2006-02-01 14:25:02 EST
python-sqlite-1.1.6-3
Comment 13 Jeremy Katz 2006-02-01 15:54:22 EST
*** Bug 179587 has been marked as a duplicate of this bug. ***
Comment 14 Dawid Gajownik 2006-02-01 16:41:41 EST
*** Bug 179648 has been marked as a duplicate of this bug. ***
Comment 15 Chitlesh GOORAH 2006-02-01 16:50:53 EST
first issue

[root@goorah ~]# rpm -qa | grep sqlite
-bash:  grep: No such file or directory

[root@goorah ~]# rpm -q sqlite
sqlite-3.3.3-1

[root@goorah ~]# rpm -e sqlite-3.3.3-1
error: Failed dependencies:
        libsqlite3.so.0 is needed by (installed) python-sqlite-1.1.6-1.1.i386
        libsqlite3.so.0 is needed by (installed) rpm-libs-4.4.2-13.i386
        libsqlite3.so.0 is needed by (installed) rpm-4.4.2-13.i386
        libsqlite3.so.0 is needed by (installed) rpm-devel-4.4.2-13.i386
        libsqlite3.so.0 is needed by (installed) rpm-build-4.4.2-13.i386
        libsqlite3.so.0 is needed by (installed) apr-util-1.2.2-4.i386
        sqlite = 3.3.3-1 is needed by (installed) sqlite-devel-3.3.3-1.i386
        sqlite is needed by (installed) mono-data-sqlite-1.1.13.2-1.i386

ive just removed digikam and its dependencies. Isn't there any other solution
than downgrading?
Comment 16 Justin Conover 2006-02-01 18:41:03 EST
Grab the version from test2 and rpm -ivh --oldpackage and you'll be fine.
Comment 17 Justin Conover 2006-02-01 18:42:53 EST
(In reply to comment #16)
> Grab the version from test2 and rpm -ivh --oldpackage and you'll be fine.

rpm -Uvh --oldpackage sqlite-3.2.8-1.i386.rpm
Comment 18 Pavel Roskin 2006-02-01 19:25:47 EST
Created attachment 124021 [details]
patch for python-sqlite

Thanks to Paul Nasrat for finding the bug (comment #11).  yum is working fine
after installing python-sqlite recompiled with this patch.  By the way, newer
versions of python-sqlite are available at http://pysqlite.org/
Comment 19 Paul Nasrat 2006-02-02 10:13:05 EST
*** Bug 176492 has been marked as a duplicate of this bug. ***
Comment 20 Need Real Name 2006-02-05 11:55:13 EST
*** Bug 180072 has been marked as a duplicate of this bug. ***
Comment 21 Jeremy Katz 2006-02-07 16:45:44 EST
*** Bug 180399 has been marked as a duplicate of this bug. ***
Comment 22 Lonni J Friedman 2006-02-07 17:13:22 EST
Can someone clue me in on where I can get this 3.2.8-1 older version of sqlite?
 I just scoured the FC ftp server, and I don't see sqlite-3.2.8-1 anywhere.  All
I've found is 3.3.3-1 (bad) and 3.2.7-2.1 (old).
Comment 23 Christopher Aillon 2006-02-07 17:18:38 EST
sqlite 3.3.3-1 is not bad, python-sqlite is.  get the version from comment 12 or
later
Comment 24 Milan Kerslager 2006-02-07 17:20:24 EST
Install python-sqlite-1.1.6-3 and you should be fine with sqlite-3.3.3-1:

http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/Fedora/RPMS/python-sqlite-1.1.6-3.i386.rpm
Comment 25 Lonni J Friedman 2006-02-07 17:49:46 EST
Thanks, that worked for me as a workaround.
Comment 26 David Lawrence 2006-02-22 13:07:41 EST
*** Bug 179648 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.