Bug 180426 - Doesn't see VIA Rhine onboard NIC
Summary: Doesn't see VIA Rhine onboard NIC
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 180427 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-02-08 02:21 UTC by Mike Cisar
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-19 14:44:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike Cisar 2006-02-08 02:21:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; InfoPath.1; .NET CLR 2.0.50727)

Description of problem:
After upgrading to 2.6.15-1.1830_FC4 the system no longer sees my onboard VIA Rhine ethernet adaptor, coming back with an error something like "adaptor doesn't seem to be present".  

If I boot back to the 2.6.14-1.1656_FC4 kernel the adaptor is detected and works fine. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot machine


Actual Results:  network adaptor not found

Expected Results:  network adaptor found

Additional info:

Comment 1 Dave Jones 2006-02-21 03:00:48 UTC
*** Bug 180427 has been marked as a duplicate of this bug. ***

Comment 2 John W. Linville 2006-02-21 15:30:16 UTC
There aren't any changes between those kernel versions that would cause the 
adapter to not be recognized.  Could this be related to bug 179891? 
 
Please try the test kernels here: 
 
   http://people.redhat.com/linville/kernels/fc4/ 
 
Does that work any better for you? 

Comment 3 mcisar 2006-02-21 19:02:27 UTC
Appears that it may be related to the other bug as you suspect.  Installed 
kernel-2.6.15-1.1832_fc4.jwltest31.i686.rpm and card detected fine.

Comment 4 mcisar 2006-03-10 15:46:09 UTC
Update, problem still present in kernel-2.6.15-1.1833_FC4

Comment 5 mcisar 2006-04-04 02:31:01 UTC
Update, problem still present in kernel-2.6.16-1.2069_FC4


Comment 6 Damon 2006-04-07 23:58:05 UTC
I am having this issue with the latest 2.6.16-1.2069_FC4 kernel and a VT6105M
Rhine-III onboard NIC, but unlike the others, the NIC works fine with
2.6.15-1.1833_FC4.  With the 2069 kernel, the system reports that the NIC seems
to not be present as indicated by others.

Comment 7 John W. Linville 2006-05-19 14:44:30 UTC
I posted a patch upstream today that should resolve the issue, once it filter 
down into Fedora.  It is equivalent to the patch from bug 179891. 


Note You need to log in before you can comment on or make changes to this bug.