Bug 18043 - anaconda failure during installation
anaconda failure during installation
Status: CLOSED DUPLICATE of bug 18031
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-01 19:12 EDT by Leston Buell
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-04 11:47:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Python traceback (1.21 KB, text/plain)
2000-10-01 19:13 EDT, Leston Buell
no flags Details

  None (edit)
Description Leston Buell 2000-10-01 19:12:06 EDT
Anaconda failed with the following traceback, aborting the installation
process. I think this was just before package selection:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py",
line 33, in __call__
    todo.getCompsList()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in
getCompsList
    self.comps = self.method.readComps(self.hdList)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 16, in
readComps
    return ComponentSet(self.tree + '/RedHat/base/comps', hdlist)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in
__init__
    self.readCompsFile(file, self.packages, arch, matchAllLang)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in
readCompsFile
    comp.addPackage(packages[l])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in
__getitem__
    return self.packages[item]
KeyError: screen

Local variables in innermost frame:
self: <comps.HeaderListFromFile instance at 82485b0>
item: screen

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Leston Buell 2000-10-01 19:13:40 EDT
Created attachment 3598 [details]
Python traceback
Comment 2 Pekka Savola 2000-10-02 16:27:54 EDT
Please make sure that 'screen' package in RedHat/RPMS/ has not been corrupted (or missing).
Comment 3 Michael Fulbright 2000-10-02 18:14:33 EDT
Is this from an official Red Hat CD or did you burn one yourself?  You should do
as the previous poster said and verify the screen package is ok.
Comment 4 Michael Fulbright 2000-10-03 15:00:59 EDT
Also, run the 'md5sum' program on the screen RPM and I'll check its not corrupt.
Comment 5 Michael Fulbright 2000-10-04 11:47:19 EDT

*** This bug has been marked as a duplicate of 18031 ***

Note You need to log in before you can comment on or make changes to this bug.