Bug 1804377 - SEGV after recirculation in batch processing in vswitchd 2.9.0
Summary: SEGV after recirculation in batch processing in vswitchd 2.9.0
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openvswitch
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Linux
urgent
high
Target Milestone: ---
: ---
Assignee: Aaron Conole
QA Contact: Eran Kuris
URL:
Whiteboard:
Depends On: 1826886
Blocks: 1770408
TreeView+ depends on / blocked
 
Reported: 2020-02-18 18:16 UTC by Aaron Conole
Modified: 2020-07-16 13:04 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1826886 (view as bug list)
Environment:
Last Closed: 2020-07-16 13:04:06 UTC
Target Upstream Version:


Attachments (Terms of Use)
With double postpone release (8.04 MB, application/x-rpm)
2020-02-24 16:13 UTC, Aaron Conole
no flags Details
python-openvswitch (188.58 KB, application/x-rpm)
2020-02-27 14:10 UTC, Aaron Conole
no flags Details

Description Aaron Conole 2020-02-18 18:16:36 UTC
Description of problem:

Thread 1 (Thread 0x7f011caab700 (LWP 104334)):
#0  0x000055d3e0c677a4 in dpcls_rule_matches_key (
    rule=rule@entry=0x7f00201772d8, target=<optimized out>)
    at ../lib/dpif-netdev.c:6935
#1  0x000055d3e0c67b53 in dpcls_lookup (cls=<optimized out>, 
    keys=keys@entry=0x7f011caa94c0, rules=rules@entry=0x7f011caa7f40, 
    cnt=cnt@entry=1, num_lookups_p=num_lookups_p@entry=0x7f011caa8018)
    at ../lib/dpif-netdev.c:7006
#2  0x000055d3e0c6e0be in fast_path_processing (pmd=pmd@entry=0x7f011caac010, 
    packets_=packets_@entry=0x7f011caaa250, keys=keys@entry=0x7f011caa94c0, 
    flow_map=flow_map@entry=0x7f011caa9370, 
    index_map=index_map@entry=0x7f011caa9360 "", in_port=11)
    at ../lib/dpif-netdev.c:5847
#3  0x000055d3e0c6f801 in dp_netdev_input__ (pmd=pmd@entry=0x7f011caac010, 
    packets=packets@entry=0x7f011caaa250, md_is_valid=md_is_valid@entry=true, 
    port_no=port_no@entry=0) at ../lib/dpif-netdev.c:5966
#4  0x000055d3e0c71249 in dp_netdev_recirculate (packets=0x7f011caaa250, 
---Type <return> to continue, or q <return> to quit---
    pmd=0x7f011caac010) at ../lib/dpif-netdev.c:6011
#5  dp_execute_cb (aux_=aux_@entry=0x7f011caaa6d0, 
    packets_=packets_@entry=0x7f011caaa250, a=a@entry=0x7f0020172b98, 
    may_steal=<optimized out>) at ../lib/dpif-netdev.c:6327
#6  0x000055d3e0ca0418 in odp_execute_actions (dp=dp@entry=0x7f011caaa6d0, 
    batch=batch@entry=0x7f011caaa250, steal=steal@entry=true, 
    actions=<optimized out>, actions_len=<optimized out>, 
    dp_execute_action=dp_execute_action@entry=0x55d3e0c70c10 <dp_execute_cb>)
    at ../lib/odp-execute.c:717
#7  0x000055d3e0c6f56b in dp_netdev_execute_actions (
    actions_len=<optimized out>, actions=<optimized out>, flow=0x7f0020177570, 
    may_steal=true, packets=<optimized out>, pmd=0x7f011caac010)
    at ../lib/dpif-netdev.c:6500
#8  packet_batch_per_flow_execute (pmd=0x7f011caac010, batch=0x7f011caaa240)
    at ../lib/dpif-netdev.c:5489
#9  dp_netdev_input__ (pmd=pmd@entry=0x7f011caac010, 
    packets=packets@entry=0x7f011caaa750, md_is_valid=md_is_valid@entry=false, 
    port_no=port_no@entry=11) at ../lib/dpif-netdev.c:5995
#10 0x000055d3e0c6ffd6 in dp_netdev_input (port_no=11, packets=0x7f011caaa750, 
    pmd=0x7f011caac010) at ../lib/dpif-netdev.c:6004
#11 dp_netdev_process_rxq_port (pmd=pmd@entry=0x7f011caac010, 
    rxq=0x55d3e3af7500, port_no=11) at ../lib/dpif-netdev.c:3798
#12 0x000055d3e0c703aa in pmd_thread_main (f_=<optimized out>)
---Type <return> to continue, or q <return> to quit---
    at ../lib/dpif-netdev.c:4680
#13 0x000055d3e0cee4df in ovsthread_wrapper (aux_=<optimized out>)
    at ../lib/ovs-thread.c:354
#14 0x00007f01c6f0fea5 in start_thread () from /lib64/libpthread.so.0
#15 0x00007f01c630d8cd in clone () from /lib64/libc.so.6


Version-Release number of selected component (if applicable):

openvswitch-2.9.0-123.bz1770408.2.el7fdp.x86_64.rpm (see branch private-aconole-bz1770408 at commit d312f60a0aa806)

How reproducible:

intermittent

Steps to Reproduce:
1. Seems to need customer environment

Actual results:

Crash.

Expected results:

No crash.

Comment 1 Aaron Conole 2020-02-18 18:50:27 UTC
Attaching

Comment 9 Aaron Conole 2020-02-24 16:13:21 UTC
Created attachment 1665475 [details]
With double postpone release

Comment 10 Aaron Conole 2020-02-24 16:13:54 UTC
NOTE this is built on the same branch as bz#1770408

Comment 13 Aaron Conole 2020-02-27 14:10:56 UTC
Created attachment 1666215 [details]
python-openvswitch

Comment 24 Bernard Cafarelli 2020-07-16 13:04:06 UTC
Since customer installed openvswitch-2.9.0-124.bz1770408.el7fdp.x86_64.rpm on 04/08 no crash was reported and customer case is closed, closing this bz too


Note You need to log in before you can comment on or make changes to this bug.