Bug 1804432 - openshift-controller-manager does not log termination messages
Summary: openshift-controller-manager does not log termination messages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: openshift-controller-manager
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.5.0
Assignee: Adam Kaplan
QA Contact: wewang
URL:
Whiteboard:
Depends On:
Blocks: 1804762
TreeView+ depends on / blocked
 
Reported: 2020-02-18 19:58 UTC by Adam Kaplan
Modified: 2020-08-04 18:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: openshift-controller-manager did not fall back to logs on termination Consequence: no termination message appears in the controller-manager pod status if it fails for any reason Fix: updated the deployment of the openshift-controller-manager to fall back to logs for its termination message Result: the last lines of the controller-manager log appear as the termination message if the controller-manager pod fails
Clone Of:
: 1804762 (view as bug list)
Environment:
Last Closed: 2020-08-04 18:00:55 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-openshift-controller-manager-operator pull 139 None closed Bug 1804432: Fallback to logs on ocm termination 2020-06-23 08:36:10 UTC
Red Hat Product Errata RHBA-2020:2409 None None None 2020-08-04 18:00:58 UTC

Description Adam Kaplan 2020-02-18 19:58:01 UTC
Description of problem:

On pod termination, the openshift-controller-manager logs are not used as the termination message.


Version-Release number of selected component (if applicable): 4.4.0


How reproducible: Sometimes


Additional info:

https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/pr-logs/pull/openshift_machine-config-operator/1484/pull-ci-openshift-machine-config-operator-master-e2e-gcp-upgrade/1098

Comment 3 wewang 2020-02-21 08:07:27 UTC
There's no vaild 4.5 nightly build payload until now, will wait for it.

Comment 4 wewang 2020-03-09 09:16:32 UTC
Now ds is include terminationMessagePolicy: FallbackToLogsOnError
version:
4.5.0-0.nightly-2020-03-06-190457

job: https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/pr-logs/pull/openshift_machine-config-operator/1541/pull-ci-openshift-machine-config-operator-master-e2e-gcp-upgrade/1322

Comment 6 errata-xmlrpc 2020-08-04 18:00:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5 image release advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:2409


Note You need to log in before you can comment on or make changes to this bug.