Bug 1804762 - [4.4.z] openshift-controller-manager does not log termination messages
Summary: [4.4.z] openshift-controller-manager does not log termination messages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: openshift-controller-manager
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Adam Kaplan
QA Contact: wewang
URL:
Whiteboard: devex
Depends On: 1804432
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-19 15:08 UTC by Adam Kaplan
Modified: 2020-05-04 11:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: openshift-controller-manager did not fall back to logs on termination Consequence: no termination message appears in the controller-manager pod status if it fails for any reason Fix: updated the deployment of the openshift-controller-manager to fall back to logs for its termination message Result: the last lines of the controller-manager log appear as the termination message if the controller-manager pod fails
Clone Of: 1804432
Environment:
Last Closed: 2020-05-04 11:37:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-openshift-controller-manager-operator pull 141 None closed Bug 1804762: Fallback to logs on ocm termination 2020-04-17 17:48:55 UTC
Red Hat Product Errata RHBA-2020:0581 None None None 2020-05-04 11:38:06 UTC

Description Adam Kaplan 2020-02-19 15:08:57 UTC
+++ This bug was initially created as a clone of Bug #1804432 +++

Description of problem:

On pod termination, the openshift-controller-manager logs are not used as the termination message.


Version-Release number of selected component (if applicable): 4.4.0


How reproducible: Sometimes


Additional info:

https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/pr-logs/pull/openshift_machine-config-operator/1484/pull-ci-openshift-machine-config-operator-master-e2e-gcp-upgrade/1098

Comment 3 wewang 2020-02-24 06:29:21 UTC
Now ds is include terminationMessagePolicy: FallbackToLogsOnError
version:
4.4.0-0.nightly-2020-02-23-183009

job: https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/pr-logs/pull/openshift_machine-config-operator/1501/pull-ci-openshift-machine-config-operator-master-e2e-gcp-upgrade/1159

Comment 5 errata-xmlrpc 2020-05-04 11:37:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.