Bug 1804598 - Installed Operators should show 'Copied' if CSV.status.reason is Copied
Summary: Installed Operators should show 'Copied' if CSV.status.reason is Copied
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.4.0
Assignee: Robb Hamilton
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2020-02-19 09:06 UTC by Yadan Pei
Modified: 2020-02-20 09:12 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-19 14:15:54 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yadan Pei 2020-02-19 09:06:12 UTC
Description of problem:
We show 'Copied' status on Installed Operators list page if CSV.status.reason in current namespace in earlier version, now it always shows 'Succeed' for all namespaces, seems like a regression brought in bug 1798858, not sure if this change is intended 

Version-Release number of selected component (if applicable):
4.4.0-0.nightly-2020-02-18-164016
 
How reproducible:
Always

Steps to Reproduce:
1. Subscribe OpenShift Pipeline Operator into all namespaces on the cluster
2. Operators -> Installed Operators -> Choose openshift-operators namespace 
3. Operators -> Installed Operators -> Choose other namespace, such as default

Actual results:
2. Status is shown 'Succeed'
3. Status is shown 'Succeed'

Expected results:
3. Status should show 'Copied'
Check csv.status.phase and csv.status.reason in 'openshift-operators' namespace
# oc get csv openshift-pipelines-operator.v0.8.2 -n openshift-operators -o json | jq '.status.phase'
"Succeeded"
# oc get csv openshift-pipelines-operator.v0.8.2 -n openshift-operators -o json | jq '.status.reason'
"InstallSucceeded"

Check csv.status.phase and csv.status.reason in 'default' namespace
# oc get csv openshift-pipelines-operator.v0.8.2 -n default -o json | jq '.status.phase'
"Succeeded"
# oc get csv openshift-pipelines-operator.v0.8.2 -n default -o json | jq '.status.reason'
"Copied"

Additional info:

Comment 1 Robb Hamilton 2020-02-19 14:15:54 UTC
Hi, Ya Dan.  This is not a regression as it is an intentional change.  See https://github.com/openshift/console/pull/4270#issuecomment-585990907

Comment 2 Yadan Pei 2020-02-20 09:12:10 UTC
Robb, Thanks for pointing me the link, it's very helpful


Note You need to log in before you can comment on or make changes to this bug.